1104 Sum of Number Segments (20分)
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).
Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10^5.
The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.
Output Specification:
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.
Sample Input:
4
0.1 0.2 0.3 0.4
Sample Output:
5.00
思路:需要找规律类型的题。自己通过列举可以发现后一个数字出现的次数与前一个数字出现的次数相关。例如:
序列:0.1 0.2 0.3 0.4,N=4
其中0.1出现4次,0.2出现了(4-1)+3 次,0.3出现了(4-2)+(3-1)+2次,0.4出现了(4-3)+(3-2)+(2-1)+1次
坑点:
sum+=data*(n-i+1)*i;
当这句话写为:sum+=(n-i+1)*i*data;
时,后两个点会答案错误,我猜测是(n-i+1)*i过大会溢出,而data<1故这样从左到右计算的时候就不会再出现溢出问题。
#include<stdio.h>
int main(){
int n;
scanf("%d",&n);
double data,sum=0;
for(int i=1;i<=n;i++){
scanf("%lf",&data);
sum+=data*(n-i+1)*i; // 有坑
}
printf("%.2f",sum);
return 0;
}