PAT自主训练记录 甲级1069/乙级1019 The Black Hole of Numbers

A1069 The Black Hole of Numbers(20分)

题目描述

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number == 6174 – the black hole== of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 1 0 4 10^4 104).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N -N=0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

题目大意

给一个不超过4位的数N,将其各个位上的数递减排,不妨记为MAX,再将其各个位上的数递增排,不妨记为MIN,用MAX-MIN得到一个新的数 N i N_i Ni,若 N i N_i Ni≠6174且 N i N_i Ni≠0,则对 N i N_i Ni进行同样的操作;若 N i N_i Ni=0或6174则停止操作。同时,将每一步的减法运算输出。

思路
写一个函数将int型的数各个位分解存入数组,再写一个函数将数组形式的数转为int。写一个排序函数,对数组内的数进行排序,从而获得被减数和减数。while循环进行减法运算,判断是否满足输出停止的条件。

过程中的弯路或错误

  • 将int数存入数组时,不需要按照原数位顺序存入,因为后面都是需要重新进行排序的。
  • 输出格式用%04d可以保证都是以4位数的形式输出的。
  • 一开始没注意输出格式要求数字与符号之间有空格。

最终正确代码

#include<stdio.h>
#include<cstdio>
#include<math.h>
#include<cmath>
#include <iostream>
#include<algorithm>
using namespace std;

//递减排序
bool cmp(int a,int b){
    return a>b;
}

//将整数n转化为数组里的数字  这里无所谓是否按照数位从高到低存入,只要把每一个数位上的数字存入数组即可
void to_array(int n,int a[]){
    for(int i=0;i<4;i++){
        a[i]=n%10;
        n=n/10;
    }
}

//将数组里的数字转化为整数
int to_num(int a[]){
    int sum=0;
    for(int i=0;i<4;i++){
        sum=sum*10+a[i];
    }
    return sum;
}

int main(int argc, const char * argv[]) {
    int n,MIN,MAX;
    scanf("%d",&n);
    int num[4];
    while(1){
        to_array(n,num);
        sort(num,num+4);
        MIN=to_num(num);
        sort(num,num+4,cmp);
        MAX=to_num(num);
        n=MAX-MIN;
        printf("%04d - %04d = %04d\n",MAX,MIN,n);//这里输入有格式要求,注意空格不能落
        if(n==0||n==6174)
            break;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值