PAT甲级1069:The Black Hole of Numbers (20)

题目

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,104).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

解题思路

本题是“数字黑洞”,中文版可见PAT乙级1019:数字黑洞(20)。对输入的数字,如果四位数字一致,则输出N - N = 0000;其余的数字,不断以4位升序排列-4位降序排列运算,直到得到6174即可。注意,不足4位的数字需要补0。

代码

#include<bits/stdc++.h>
using namespace std;
int cmp1(const void *a, const void *b){
    return *(char *)b-*(char *)a;//降序
}

int cmp2(const void *a, const void *b){
    return *(char *)a-*(char *)b;//升序
}

int main(){
    char a[5],b[5];
    int diff,lena,temp,k;
    scanf("%s",a);//原始数据
    if (strlen(a)==4 && a[0]==a[1] && a[1]==a[2] && a[2]==a[3])
        printf("%s - %s = 0000",a,a);
    else
    {
        while (diff!=6174){
            lena = strlen(a);
            while (lena!=4){
                a[lena++] = '0';}//补齐为4位
            a[4] = '\0';
            strcpy(b,a);
            qsort(a,4,sizeof(char),cmp1);
            qsort(b,4,sizeof(char),cmp2);
            diff = atoi(a)-atoi(b);
            printf("%s - %s = %04d\n",a,b,diff);
            temp = diff;
            k = 0;
            while (temp!=0){
                a[k++] = temp%10+48;//更新a
                temp/=10;
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值