PAT甲级真题 1069 The Black Hole of Numbers (20分) C++实现(同乙级1019)

该博客详细介绍了PAT甲级编程竞赛中的1069题——数字黑洞(Kaprekar Constant)问题。通过举例说明,解释了从任意4位数出发如何通过特定操作最终得到6174的过程。当输入数字的4个数字相同时,输出"N - N = 0000";否则,逐次展示每次操作得到的差值,直到出现6174。文章重点讨论了C++中sort、reverse、stoi、to_string等库函数的应用,并提及了柳神的一种字符串补零的方法。
摘要由CSDN通过智能技术生成

题目

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation “N - N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:

2222 - 2222 = 0000

思路

PAT乙级真题 1019 数字黑洞 C++实现,主要是sort、reverse、stoi、to_string等库函数的使用。

柳神用了:s.insert(0, 4 – s.length(), ‘0’);来给不足4位的字符串前面补0,学习了。

代码

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

int main(){
    string s;
    cin >> s;
    int a, b, c;
    do{
        while (s.size() < 4){
            s += '0';
        }
        sort(s.begin(), s.end());
        b = stoi(s);
        reverse(s.begin(), s.end());
        a = stoi(s);
        c = a - b;
        printf("%04d - %04d = %04d\n", a, b, c);
        s = to_string(c);
    }while (c!=0 && c!=6174);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值