POJ 2456 Aggressive cows 简单二分

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15803 Accepted: 7573

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Link:http://poj.org/problem?id=2456


题意:攻击性的牛,为了让牛尽可能不互相攻击,寻找一个牛栏间隔最大距离,能放进所有牛,N为牛栏数,C为牛个数,N行为牛栏所在坐标点


思路:二分法查找牛栏距离,关键在于判断函数


AC code:

#include <cstdio>
#include <algorithm>
using namespace std;


long long a[100050];
long long  mid,cnt;
long long  n,c;
long long  l,r;


int judge(int mid){
    long long  temp=a[0];
    cnt=0;
    for(int i=0;i<n;i++){
        if(a[i]-temp>=mid){
            temp=a[i];
            cnt++;
            //及时返回 否则容易TLE
            if(cnt>=c) return 1;
        }
    }
    return 0;
}


int main()
{
    while(scanf("%lld%lld",&n,&c)!=EOF){
        //个数减一 因为cnt按合法间距累加
        c=c-1;
        for(int i=0;i<n;i++){
            scanf("%lld",&a[i]);
        }
        sort(a,a+n);
        l=a[0];
        r=a[n-1];
        cnt=0;
        //二分框架
        while(l<r){
            //满足即跳出
            if(l+1>=r&&cnt==c) break;
            mid=(l+r)/2;
            if(judge(mid)) l=mid;
            else r=mid;
        }
        printf("%lld\n",mid);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值