HDU - 2586 How far away ?(LCA tarjan离线做法)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19232    Accepted Submission(s): 7525


Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input
  
  
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output
  
  
10 25 100 100
 

Source
 

Recommend
lcy
 

Statistic |  Submit |  Discuss | Note


题意:一个村庄有n个房子,有n-1条路径(类似一棵树),有q个查询,查询x到y的距离;

分析:树的节点之间的距离,LCA模板题


贴个模板:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <stack>
#include <string>
#include <map>
using namespace std;
#define LL long long
#define INF 0x3f3f3f3f
const int MAXN = 80080;
const int MAXQ = 440;

struct EdgeNode
{
	int from;
    int to;
    int next;
    int lca;
}Edges[MAXN],QEdges[MAXQ];

int Head[MAXN],QHead[MAXN];		//离线查询
int father[MAXN],Dist[MAXN];
bool vis[MAXN];
int id,ip;

int Find(int x)
{
    return father[x]==x?x:father[x]=Find(father[x]);
}

void LCA(int u)
{
    father[u] = u;
    vis[u] = true;
    for(int k = Head[u]; k != -1; k = Edges[k].next)
    {
        if(!vis[Edges[k].to])
        {
            Dist[Edges[k].to] = Dist[u] + Edges[k].lca;
            LCA(Edges[k].to);
            father[Edges[k].to] = u;
        }
    }
    for(int k = QHead[u]; k != -1; k = QEdges[k].next)
    {
        if(vis[QEdges[k].to])
        {
            QEdges[k].lca = Dist[u] + Dist[QEdges[k].to] - 2*Dist[Find(QEdges[k].to)];
            QEdges[k^1].lca = QEdges[k].lca;
        }
    }
}

void init(){
	id=ip=0;
	memset(father,0,sizeof(father));
    memset(Dist,0,sizeof(Dist));
    memset(vis,false,sizeof(vis));
    memset(Head,-1,sizeof(Head));
    memset(QHead,-1,sizeof(QHead));
}

void addedge(int u,int v,int w){
	Edges[id].from=u;
	Edges[id].to = v;
    Edges[id].lca = w;
    Edges[id].next = Head[u];
    Head[u] = id++;
}

void addQedge(int u,int v){
	QEdges[ip].from = u;
	QEdges[ip].to = v;
    QEdges[ip].next = QHead[u];
    QHead[u] = ip++;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        init();
        for(int i = 2; i <= n; ++i)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
            addedge(v,u,w);
        }
        for(int i = 1; i <= m; ++i)
        {
        	int u,v;
            scanf("%d%d",&u,&v);
            addQedge(u,v);
            addQedge(v,u);
        }
        LCA(1);
        for(int i = 0; i < ip; i += 2)
            printf("%d\n",QEdges[i].lca);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值