HDU 4280 Island Transport (ISPA)

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 9784    Accepted Submission(s): 3174


Problem Description
  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
 

Input
  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
 

Output
  For each test case, output an integer in one line, the transport capacity.
 

Sample Input
  
  
2 5 7 3 3 3 0 3 1 0 0 4 5 1 3 3 2 3 4 2 4 3 1 5 6 4 5 3 1 4 4 3 4 2 6 7 -1 -1 0 1 0 2 1 0 1 1 2 3 1 2 1 2 3 6 4 5 5 5 6 3 1 4 6 2 5 5 3 6 4
 

Sample Output
  
  
9 6
 

Source
 

Recommend
liuyiding
 

Statistic |  Submit |  Discuss | Note


题意:很简单的题意,有N个岛屿 M条无向路 每个路有一最大允许的客流量,求从最西的那个岛屿最多能运用多少乘客到最东的那个岛屿;


分析:是最大流模板题,把最西和最东边的岛屿编号找出来就可以直接上模板了;

但是DINIC超时了!!!题目给了10s的时间限制,无奈百度了一下有没有更快的算法:

SAP详解

代码量巨可怕.....

直接上了ISAP模板:


/*
 *ISAP+bfs初始化+栈优化
 */
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <stack>
#include <string>
#include <map>
using namespace std;
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;

const int maxn=100010;      //点数的最大值
const int maxm=400010;      //边数的最大值

struct Edge {
    int to,next,cap,flow;
} edge[maxm];               //注意是maxm

int tol;
int Head[maxn];
int cur[maxn],Dis[maxn];    // 当前弧下标   结点到汇点距离下界
int gap[maxn];      		//可增广路上的上一条弧  gap优化

void init() {
    tol=0;
    memset(Head, -1, sizeof(Head));
}

void addedge(int u,int v,int w,int rw = 0) {
    edge[tol].to=v;
    edge[tol].cap=w;
    edge[tol].flow=0;
    edge[tol].next=Head[u];
    Head[u]=tol++;
    edge[tol].to=u;
    edge[tol].cap=w;		//因为是无向 因此不需要反向边
    //edge[tol].cap=rw;
    edge[tol].flow=0;		
    edge[tol].next=Head[v];
    Head[v]=tol++;
}

int Q[maxn];				//模拟栈
void bfs(int s,int t) { 	//逆向进行bfs
    memset(Dis, -1, sizeof(Dis));
    memset(gap, 0, sizeof(gap));
    gap[0]=1;
    int front=0, rear=0;
    Dis[t]=0;
    Q[rear++]=t;
    while(front!=rear) {
        int u=Q[front++];
        for(int i=Head[u]; i!=-1; i=edge[i].next) {
            int v=edge[i].to;
            if(Dis[v]!=-1)continue;
            Q[rear++]=v;
            Dis[v]=Dis[u]+1;
            gap[Dis[v]]++;
        }
    }
}

int S[maxn];
int sap(int s,int t) {
    bfs(s, t);
    memcpy(cur, Head, sizeof(Head));
    int top=0;
    int u=s;
    int ans=0;
    while(Dis[s]<INF) {
        if(u==t) {
            int Min=INF;
            int inser;
            for(int i=0; i<top; i++)	//找最小残量值
                if(Min>edge[S[i]].cap-edge[S[i]].flow) {
                    Min=edge[S[i]].cap-edge[S[i]].flow;
                    inser=i;
                }
            for(int i=0; i<top; i++) { 	//增广
                edge[S[i]].flow+=Min;
                edge[S[i]^1].flow-=Min;
            }
            ans+=Min;
            top=inser;
            u=edge[S[top]^1].to;
            continue;
        }
        bool ok=false;
        int v;
        for(int i=cur[u]; i!=-1; i=edge[i].next) {
            v=edge[i].to;
            if(edge[i].cap-edge[i].flow && Dis[v]+1==Dis[u]) { //Advance前进
                ok=true;
                cur[u]=i;
                break;
            }
        }
        if(ok) {
            S[top++]=cur[u];
            u=v;
            continue;
        }
        //Retreat走不动了 撤退
        int Min=INF;
        for(int i=Head[u]; i!=-1; i=edge[i].next)
            if(edge[i].cap-edge[i].flow && Dis[edge[i].to]<Min) {
                Min=Dis[edge[i].to];
                cur[u]=i;
            }
        gap[Dis[u]]--;
        if(!gap[Dis[u]])return ans;
        Dis[u]=Min+1;
        gap[Dis[u]]++;
        if(u!=s)u=edge[S[--top]^1].to;//退一步,沿父边返回
    }
    return ans;
}



int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,m;
		scanf("%d%d",&n,&m);
		init();
		pair<int ,int> west,east;
		west.first=INF;
		east.first=-INF;
		for(int i=1;i<=n;i++){
			int x,y;
			scanf("%d%d",&x,&y);
			if(x>=east.first) {
				east.first=x;
				east.second=i;
			}
			if(x<=west.first) {
				west.first=x;
				west.second=i;
			}
		}
		int st=west.second;
		int ed=east.second;
		for(int i=1;i<=m;i++){
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			addedge(a,b,c);
		}
		int ans=sap(st,ed);
		printf("%d\n", ans);
	}
	return 0;
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值