1038 Recover the Smallest Number (30分) C++实现 sort(,,[])

1038 Recover the Smallest Number (30分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification1038:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

核心排序代码:

sort(s,s+n,[](string a,string b)
	{
		return a + b < b + a;
	});

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int N = 1e4+10;
string s[N];
int main()
{
	int n,bit=0; cin>>n;
	for(int i=0;i<n;i++) cin>>s[i];
	sort(s,s+n,[](string a,string b)
	{
		return a + b < b + a;
	});
	string ans;
	for(int i=0;i<n;i++)
		ans+=s[i];
	while(bit + 1 < ans.size() && ans[bit]=='0') bit++; //查找第一位不为0的,bit+1是确保整个字符串为0时只会输出一个0,无需进行特殊判断。
	cout<<ans.substr(bit);    //输出整个字符串的子串(从k开始)
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Jay_fearless

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值