1038 Recover the Smallest Number(30 分)(C++)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

一开始拿到题我也很无奈,感觉处理起来很麻烦,后来参考了一下其他人的,才意识到字符串还能这么用,学的还是不够扎实。闲话不说,我们看一下本题的知识点。

知识点:

1、重中之重就是那个比较运算,两个字符串相加直接比较大小,完美的解决了首位为0的问题。

2、去掉字符串前面的0;erase(s.begin())

关于erase有以下的三种用法

(1)erase(pos,n); 删除从pos开始的n个字符,比如erase(0,1)就是删除第一个字符

(2)erase(position);删除position处的一个字符(position是个string类型的迭代器)

(3)erase(first,last);删除从first到last之间的字符(first和last都是迭代器)

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
int cmp(string a, string b){
	return a + b < b + a;
}
int main(){
	int n;
	scanf("%d",&n);
	vector<string>v(n);
	string ans;
	for(int i = 0; i < n; ++ i)
		cin >> v[i];
	sort(v.begin(), v.end(), cmp);
	for(int i = 0; i < n; ++ i)
		ans += v[i];
	while(ans.length() > 1 && ans[0] == '0')
		ans.erase(ans.begin());
	printf("%s",ans.c_str());
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值