hdu 2955 Robbies

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6


思路:题意是大致是在不被抓到概率的情况下要抢尽可能多的银行。每个银行只有抢和不抢两种情况,符合0/1背包的问题。丧病的背包!开始天真的直接把概率当做下标,求价值的最大,也就是dp[i]来表示不被抓的概率为i的情况下能抢到的最大价值。而后发现概率不能像平常的0/1背包的重量一样单纯相加减。只能转换一下,把价值当做下标求概率。而后思考问题又会陷入一个误区:(比如抢A银行被抓概率0.4,B银行0.6,并不是同时抢A,B银行的概率就变成了0.4*0.6=0.24,越抢越安全...要这样银行早被抢光了...而应该是1-(1-0.6)*(1-0.4)=0.76才对)。于是把每一个被抓概率转换为不被抓(即能够逃脱)的概率,总被抓概率变为总逃脱概率。于是dp[i]变成了在抢了i元的情况下最大逃脱概率。最后在找到第一个dp[i]>=m(总概率)的i即为所求。



#include<iostream>
#include<cstring>
using namespace std;
const int maxn=1e5+5;
double w[maxn],dp[maxn];
int v[maxn];
int main(){
	double m;int n;
	int t;
	cin>>t;
	while(t--)
	{
		memset(dp,0,sizeof(dp));
		cin>>m>>n;
		m=1-m;
		int N=0;
		for(int i=1;i<=n;i++){
			cin>>v[i]>>w[i];
			N+=v[i];
			w[i]=1-w[i];		
		}
		dp[0]=1;
		for(int i=1;i<=n;i++){
			for(int j=N;j>=v[i];j--){
				dp[j]=max(dp[j],dp[j-v[i]]*w[i]);
		//		cout<<dp[j]<<' ';
			}
		//	cout<<endl;
		}
		int i;
		for(i=N;i>=1;i--){
			if(dp[i]>=m) break;
		}
		cout<<i<<endl;
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值