Aladdin and the Flying Carpet LightOJ - 1341--数论

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.
Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.
Output

For each case, print the case number and the number of possible carpets.
Sample Input

2
10 2
12 2

Sample Output

Case 1: 1
Case 2: 2

题意:据说阿拉丁必须先解开七个谜团才能得到召唤着一个强大精灵的神灯。这里我们关注的是第一个谜团。

阿拉丁即将进入一个神奇的洞穴,由化装成阿拉丁叔叔的邪恶巫师带领,在洞口发现了一块神奇的飞毯。有一些奇怪的生物守卫着洞口。阿拉丁可以逃跑,但他知道被抓住的可能性很大。所以,他决定使用神奇的飞毯。地毯是长方形的,不是方形的。阿拉丁拿起地毯,在它的帮助下通过了入口。

现在已知地毯的面积和地毯可能的最小边的长度,您的任务是找出可能有多少种地毯。例如,地毯的面积为12,地毯的最小可能边是2,那么就可以有两种地毯,它们的边是:{2,6}和{3,4}。

输入两个数a,b;a代表飞毯面积,b代表最小边的长度

题解:给你n和m,让你求n的因子中大于或等于m的个数。
唯一分解之后,dfs搜索出所有a的因数

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
#define maxn 1000010
bool isprime[maxn];
long long int prime[maxn/10];
long long int top;
void is_prime()
{
    top=0;
    memset(isprime,true,sizeof(isprime));
    for(long long int i=2; i<=maxn; i++)
    {
        if(isprime[i])
            prime[top++]=i;
//            cout<<i<<endl;
        for(long long int j=0; j<top&&i*prime[j]<=maxn; j++)
        {
            isprime[i*prime[j]]=false;
            if(i%prime[j]==0)
                break;
        }
    }
}
int main()
{
    is_prime();
    int t;
    scanf("%d",&t);
    int cas=0;
    while(t--)
    {
        long long int n,m;
        scanf("%lld%lld",&n,&m);
        long long int sum=1;
        long long int a;
        long long int x=n;
        long long int ans;
        if(m>=sqrt(n))
        {
            ans=0;
        }
        else
        {
            long long int i=0;
            while(prime[i]<x&&i<top)
            {
                a=0;
                if(x%prime[i]==0)
                {
//                x/=prime[i];
                    while(x%prime[i]==0)
                    {
                        a++;
                        x/=prime[i];
                    }
                }
                sum*=1+a;
                i++;
            }
            if(x>1)
                sum*=2;
            long long int cnt=0;
            for(long long int i=1; i<m; i++)
            {
                if(n%i==0)
                    cnt++;
            }
            sum/=2;
            ans=sum-cnt;
        }
            printf("Case %d: %lld\n",++cas,ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

JdiLfc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值