Aladdin and the Flying Carpet LightOJ - 1341(算数基本定理)

Aladdin and the Flying Carpet

LightOJ - 1341

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.


Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

算术基本定理又叫唯一分解定理。
算术基本定理内容:任何一个大于1的自然数 ,都可以唯一分解成有限个质数的乘积 这里写图片描述 ,这里 这里写图片描述均为质数,其中指数 ai是正整数。


算术基本定理的几个应用:
下面的p1,p2…pn都是素数。
这里写图片描述

同时全体正因数的和也可以写作:
这里写图片描述


本题就是第一个应用。
有几个注意的地方:获得质数的个数的时候,可以先不筛选素数,但是本题时间卡的紧,必须要先筛素数。还有注意当b*b>=a的时候就特判。


最后把总的个数除2然后减去因数小于要求的最小因数的情况

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
const int MAXN = 1e6+10;
int t;
int primes[MAXN];
bool isprime[MAXN];
void getPrime(){
    memset(isprime,true,sizeof(isprime));
    isprime[0] = isprime[1] = false;
    t = 0;
    for(int i = 2; i < MAXN; i++){
        if(isprime[i]){
            primes[t++] = i;
            for(int j = i + i; j < MAXN; j += i){
                isprime[j] = false;
            }
        }
    }
    return;
}
int getfac(ll x){
    int ans = 1;
    for(int i = 0; i < t && primes[i] * primes[i] <= x; i++){
        if(x == 1) break;
        int tmp = 0;
        while(x % primes[i] == 0){
            tmp++;
            x /= primes[i];
        }
        ans *= (tmp + 1);
    }
    if(x != 1) ans *= 2;//ans = ans * (1 + 1);
    return ans;
}
int main(){
    getPrime();
    int t;
    int cas = 0;
    scanf("%d",&t);
    while(t--){
        ll a,b;
        scanf("%lld%lld",&a,&b);
        if(b * b >= a){//因为题目要求不是正方形,并且另一条边一定大于b
            printf("Case %d: 0\n",++cas);
            continue;
        }
        int ans = getfac(a);
        ans /= 2;//因子对,所以除2
        for(int i = 1; i < b; i++){
            if(a % i == 0) ans--;//将小于要求的最小因数的情况去掉
        }
        printf("Case %d: %d\n",++cas,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值