[PAT] A1009 Product of Polynomials


This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2Nk aNk
where K is the number of nonzero terms in the polynomial,Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤Nk< … <N2<N1≤1000.

Output Specification

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

Code

多项式乘法,需要注意的是:
1、会有测试点测试系数为0的项,系数为0不输出;
2、数组开够了,否则后两个测试点会段溢出;
3、如果最后多项式为0的话,直接输出一个0(count)。

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    float coea[3000]={0.0},coeb[3000]={0.0},coes[3000]={0.0};
    int expa[3000]={0},expb[3000]={0},exps[3000]={0};
    int exp,minn=0,maxx=0,maxx2=0;
    float coe;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>exp>>coe;
        expa[exp]++;
        coea[exp]+=coe;
        if(exp>maxx)
            maxx=exp;
        if(exp<minn)
            minn=exp;
    }
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>exp>>coe;
        expb[exp]++;
        coeb[exp]+=coe;
        if(exp>maxx)
            maxx=exp;
        if(exp<minn)
            minn=exp;
    }
    for(int i=0;i<=maxx;i++)
    {
        if(expa[i])
        {
            for(int j=0;j<=maxx;j++)
            {
                if(expb[j])
                {
                    if(coea[i] || coeb[i])
                    {
                        int sumex;
                        float sumco;
                        sumex = i+j;
                        exps[sumex]++;
                        if(sumex>maxx2)
                            maxx2=sumex;
                        sumco = coea[i] * coeb[j];
                        coes[sumex] +=sumco;
                    }
                }
            }
        }
    }

    int cnt=0,cnt1=0;
    for(int i=0;i<=maxx2;i++)
        if(exps[i] && coes[i])
            cnt++;
    if(cnt)
        cout<<cnt<<" ";
    else
        cout<<cnt;
    for(int i=maxx2;i>=0;i--)
    {
        cout.setf(ios::fixed);
        if(exps[i] && coes[i])
        {
            cnt1++;
            cout<<i<<" ";
            if(cnt1!=cnt)
                cout<<setprecision(1)<<coes[i]<<" ";
            else
                cout<<setprecision(1)<<coes[i];
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值