PAT A1009 Product of Polynomials (25分)

75 篇文章 0 订阅

PAT A1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​​ a​N1 N​2​​ a​N​2​​ ​ … NK​ a​N​K where K is the number of nonzero terms in the polynomial, Ni​​ and aN​i​​ ​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​ <⋯<N2​​ <N1≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6

以下是AC的代码:

#include<cstdio>
#define maxn 1000100
double pa[maxn],pb[maxn];
int main(void){
	for(int i=0;i<maxn;i++){
		pb[i]=pa[i]=0;}
	int total,te;
	double tc;
	int count =0;
	scanf("%d",&total);
	for(int i=0;i<total;i++){
		scanf("%d%lf",&te,&tc);
		pa[te]=tc;
	}
	scanf("%d",&total);
	for(int i=0;i<total;i++){
		scanf("%d%lf",&te,&tc);
		for(int j=0;j<maxn;j++){
			double tmp=pa[j]*tc;
			pb[j+te]+=tmp;
		}
	}
	for(int i=0;i<maxn;i++){
		if(pb[i]!=0)count++;
	}
	printf("%d",count);
	for(int i=maxn-1;i>=0;i--){
		if(pb[i]!=0)printf(" %d %.1f",i,pb[i]);
	}
	return 0;
}

思路:
与A1002,B1010相似,使用一个数组记录待乘的A数组,一边读第二个数组一边将结果加入答案数组中。这里我自己做的时候很明显,为什么把maxn设置到1 000 100这个数量级,是因为我想错了,以为1000幂次相乘会变成1 000 000. 虽然不影响程序AC,如果换一个时间要求,可能就过不了了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值