Hdu3363 Ice-sugar Gourd

14 篇文章 0 订阅

Ice-sugar Gourd

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1492    Accepted Submission(s): 471


Problem Description
Ice-sugar gourd, “bing tang hu lu”, is a popular snack in Beijing of China. It is made of some fruits threaded by a stick. The complicated feeling will be like a both sour and sweet ice when you taste it. You are making your mouth water, aren’t you?

I have made a huge ice-sugar gourd by two kinds of fruit, hawthorn and tangerine, in no particular order. Since I want to share it with two of my friends, Felicia and his girl friend, I need to get an equal cut of the hawthorns and tangerines. How many times will I have to cut the stick so that each of my friends gets half the hawthorns and half the tangerines? Please notice that you can only cut the stick between two adjacent fruits, that you cannot cut a fruit in half as this fruit would be no good to eat.
 

Input
The input consists of multiply test cases. The first line of each test case contains an integer, n(1 <= n <= 100000), indicating the number of the fruits on the stick. The next line consists of a string with length n, which contains only ‘H’ (means hawthorn) and ‘T’ (means tangerine).
The last test case is followed by a single line containing one zero.
 

Output
Output the minimum number of times that you need to cut the stick or “-1” if you cannot get an equal cut. If there is a solution, please output that cuts on the next line, separated by one space. If you cut the stick after the i-th (indexed from 1) fruit, then you should output number i to indicate this cut. If there are more than one solution, please take the minimum number of the leftist cut. If there is still a tie, then take the second, and so on.
 

Sample Input
  
  
4 HHTT 4 HTHT 4 HHHT 0
 

Sample Output
  
  
2 1 3 1 2 -1
 


____________________________________________________________________________________

解题大意:
给你一个串,串中有H跟T两种字符,然后切任意刀,使得能把H跟T各自分为原来的一半。
解题思路:
把串想象成一个环,只要满足H跟T都为偶数个,那么就可以做一条过圆心的直线把H跟T平分掉,
过直线,只要考虑平分H或者T中的一个就可以了,因为直线本来就把环平分,而此时平分了H或者T,
那么剩下的那个也是平分掉的。
暴力枚举即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <queue>
#include <vector>
#include <stack>
#include <set>

using namespace std;

char s[100005];

int main()
{
   int n;
   while(~scanf("%d",&n)&&n)
   {
       scanf("%s",s);
       int H=0,T=0;
       for(int i=0;i<n;i++)
       {
           if(s[i]=='H')
            H++;
           else
           T++;
       }
       if(H%2||T%2)
       {
           printf("-1\n");
           continue;
       }
       int h=0,t=0;
       for(int i=0;i<n/2;i++)
       {
           if(s[i]=='H')
            h++;
           else
           t++;
       }
       if(h==H/2&&t==T/2)
       {
           printf("1\n%d\n",n/2);
           continue;
       }
        int p=0;
       for(int i=n/2;i<n;i++,p++)
       {
           if(t==T/2&&h==H/2)
           {
               printf("2\n%d %d\n",p,i);
               break;
           }
           if(s[p]=='H')
           h--;
           else
            t--;
           if(s[i]=='H')
            h++;
           else
            t++;
       }
   }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值