Ice-sugar Gourd

Ice-sugar Gourd

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 568    Accepted Submission(s): 207


Problem Description
Ice-sugar gourd, “bing tang hu lu”, is a popular snack in Beijing of China. It is made of some fruits threaded by a stick. The complicated feeling will be like a both sour and sweet ice when you taste it. You are making your mouth water, aren’t you?

I have made a huge ice-sugar gourd by two kinds of fruit, hawthorn and tangerine, in no particular order. Since I want to share it with two of my friends, Felicia and his girl friend, I need to get an equal cut of the hawthorns and tangerines. How many times will I have to cut the stick so that each of my friends gets half the hawthorns and half the tangerines? Please notice that you can only cut the stick between two adjacent fruits, that you cannot cut a fruit in half as this fruit would be no good to eat.


 

Input
The input consists of multiply test cases. The first line of each test case contains an integer, n(1 <= n <= 100000), indicating the number of the fruits on the stick. The next line consists of a string with length n, which contains only ‘H’ (means hawthorn) and ‘T’ (means tangerine).
The last test case is followed by a single line containing one zero.
Output
Output the minimum number of times that you need to cut the stick or “-1” if you cannot get an equal cut. If there is a solution, please output that cuts on the next line, separated by one space. If you cut the stick after the i-th (indexed from 1) fruit, then you should output number i to indicate this cut. If there are more than one solution, please take the minimum number of the leftist cut. If there is still a tie, then take the second, and so on.
Sample Input
  
  
4 HHTT 4 HTHT 4 HHHT 0
Sample Output
  
  
2 1 3 1 2 -1
Source
Recommend
lcy
 
有两种水果的冰糖葫芦串,求用最少的刀数把两种水果平均分成两份,只能在相邻的水果处下刀。
这道题的难点在于推断出最多只需要切两刀,我们知道如果水果数为odd的话,就不存在解了。
当水果数不为odd时,我们可以把用一个n/2大小的区间去搜索整个串,当这个n/2大小的区间中存在且只存在1/2的某一种水果时,我们知道,这个区间就是我们所要得到的区间,区间的头和尾,就是题目的解。
通过简单的数学推理可知,如果存在解,这个区间就一定存在,所以最多只需切两刀。
 
#include <cstdio>

#include <cstring>

using namespace std;




int main(){

	 int n;

	 while(scanf("%d",&n)==1&&n){

		 static char str[100010];

		 static int hn[100010];

		 scanf("%s",str);

		 if (n%2!=0){

			 printf("-1\n");

			 continue;

		 }

		 int h=0;

		 for (int i=0;i<n;++i){

			 if(str[i]=='H')

				 ++h;

			 hn[i]=h;

		 }

		 if (h%2!=0){

			 printf("-1\n");

			 continue;

		 }

		 if(hn[n/2-1]==h/2){

				 printf("1\n%d\n",n/2);

				 continue;

		 }

		 for (int i=1;i<n/2;++i){

			 if ((hn[i+n/2-1]-hn[i-1])==h/2){

				 printf("2\n%d %d\n",i,i+n/2);

				 break;

				 }

			 }

	 }

	 return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值