ZOJ2482 IP Address

IP Address

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:

2726252423222120
1286432168421

Input

The input will have a number N (1 <= N <= 9) in its first line representing the number of streams to convert. N lines will follow.


Output

The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.


Sample Input

4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001


Sample Output

0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1


——————————————————————————————————

给出一个32位二进制,化成点分十进制的IP地址形式

8位一处理即可


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <set>
#include <stack>
#include <map>
#include <functional>
#include <bitset>
#include <string>

using namespace std;

#define LL long long
#define INF 0x3f3f3f3f


int main()
{
    int T;
    char s[1000];
    int a[10];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",s);
         a[8]=1;
        for(int i=7;i>0;i--)
        a[i]=2*a[i+1];
        int a1=0,a2=0,a3=0,a4=0;
        int cnt;
        cnt=1;
        for(int i=0;i<8;i++)
        {
            a1+=(s[i]-'0')*a[cnt++];
        }
        cnt=1;
        for(int i=8;i<16;i++)
        {
            a2+=(s[i]-'0')*a[cnt++];
        }
        cnt=1;
        for(int i=16;i<24;i++)
        {
            a3+=(s[i]-'0')*a[cnt++];
        }
        cnt=1;
        for(int i=24;i<32;i++)
        {
            a4+=(s[i]-'0')*a[cnt++];
        }
        printf("%d.%d.%d.%d\n",a1,a2,a3,a4);

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值