Time Limit: 2000MS | Memory Limit: 65536KB | 64bit IO Format: %lld & %llu |
Description
Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:
27 | 26 | 25 | 24 | 23 | 22 | 21 | 20 |
128 | 64 | 32 | 16 | 8 | 4 | 2 | 1 |
Input
The input will have a number N (1 <= N <= 9) in its first line representing the number of streams to convert. N lines will follow.
Output
The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.
Sample Input
4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001
Sample Output
0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1
Source
#include <iostream>
#include<cstdio>
using namespace std;
int main()
{
int pos[8]={128,64,32,16,8,4,2,1};//顺序反过来
char c;
int n,i,j;
int sum;
scanf("%d",&n);
while(n--)
{
for(i=0;i<4;i++)
{
sum=0;
for(j=0;j<8;j++)
{
//scanf("%c",&c);//cin>>c才能配合c-='0'这种用法。但不知道为什么????
cin>>c;
//c-='0';//记住这种用法,此时c转换为int型.或c-=48;
c-=48;
if(c)//此时c转换为int型
sum+=pos[j];
}
if(i)
printf(".");
printf("%d",sum);
}
printf("\n");
}
return 0;
}