Hdu6077 Time To Get Up(2017多校第4场)

75 篇文章 0 订阅

Time To Get Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 240    Accepted Submission(s): 197


Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  5  alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer  T(1T1440) , denoting the number of test cases.

In each test case, there is an  7×21  ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string  t  in the format of  HH:MM , where  t(00:00t23:59) , denoting the time shown on the clock.
 

Sample Input
  
  
1 .XX...XX.....XX...XX. X..X....X......X.X..X X..X....X.X....X.X..X ......XX.....XX...XX. X..X.X....X....X.X..X X..X.X.........X.X..X .XX...XX.....XX...XX.
 

Sample Output
  
  
02:38
 

Source
 

Recommend
liuyiding

————————————————————————————————————

题目的意思是给出一个7*21的图输出时间

思路:现场队友打的,直接对每位特征特判处理,很不优雅


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
const LL mod=1000000007;

char ch[10][50];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        for(int i=0;i<7;i++) scanf("%s",ch[i]);
        int a,b,c,d;
        if(ch[0][1]=='X')
        {
            if(ch[1][0]=='X')
            {
                if(ch[1][3]=='X')
                {
                    if(ch[3][1]=='.') a=0;
                    else if(ch[4][0]=='X') a=8;
                    else a=9;
                }
                else if(ch[4][0]=='X') a=6;
                else a=5;
            }
            else if(ch[3][1]=='.') a=7;
            else if(ch[4][0]=='X') a=2;
            else a=3;
        }
        else if(ch[3][1]=='X') a=4;
        else a=1;
        if(ch[0][6]=='X')
        {
            if(ch[1][5]=='X')
            {
                if(ch[1][8]=='X')
                {
                    if(ch[3][6]=='.') b=0;
                    else if(ch[4][5]=='X') b=8;
                    else b=9;
                }
                else if(ch[4][5]=='X') b=6;
                else b=5;
            }
            else if(ch[3][6]=='.') b=7;
            else if(ch[4][5]=='X') b=2;
            else b=3;
        }
        else if(ch[3][6]=='X') b=4;
        else b=1;
        if(ch[0][13]=='X')
        {
            if(ch[1][12]=='X')
            {
                if(ch[1][15]=='X')
                {
                    if(ch[3][13]=='.') c=0;
                    else if(ch[4][12]=='X') c=8;
                    else c=9;
                }
                else if(ch[4][12]=='X') c=6;
                else c=5;
            }
            else if(ch[3][13]=='.') c=7;
            else if(ch[4][12]=='X') c=2;
            else c=3;
        }
        else if(ch[3][13]=='X') c=4;
        else c=1;
        if(ch[0][18]=='X')
        {
            if(ch[1][17]=='X')
            {
                if(ch[1][20]=='X')
                {
                    if(ch[3][18]=='.') d=0;
                    else if(ch[4][17]=='X') d=8;
                    else d=9;
                }
                else if(ch[4][17]=='X') d=6;
                else d=5;
            }
            else if(ch[3][18]=='.') d=7;
            else if(ch[4][17]=='X') d=2;
            else d=3;
        }
        else if(ch[3][18]=='X') d=4;
        else d=1;
        printf("%d%d:%d%d\n",a,b,c,d);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值