HDU 6077 Time To Get Up -暴力枚举-2017多校联盟4 第11题

Time To Get Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has 5 alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer T(1T1440) , denoting the number of test cases.

In each test case, there is an 7×21 ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string t in the format of HH:MM , where t(00:00t23:59) , denoting the time shown on the clock.
 

Sample Input
  
  
1 .XX...XX.....XX...XX. X..X....X......X.X..X X..X....X.X....X.X..X ......XX.....XX...XX. X..X.X....X....X.X..X X..X.X.........X.X..X .XX...XX.....XX...XX.
 

Sample Output
  
  
02:38


题意:

读出用x组成的7字数码管的显示值,格式是HH:MM


解题思路
一共四位,每位有0~9 这10中可能,枚举对比一下就好。

代码
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const char num[10][7][5] = {".XX.", "X..X", "X..X", "....", "X..X", "X..X", ".XX.",
                            "....", "...X", "...X", "....", "...X", "...X", "....",
                            ".XX.", "...X", "...X", ".XX.", "X...", "X...", ".XX.",
                            ".XX.", "...X", "...X", ".XX.", "...X", "...X", ".XX.",
                            "....", "X..X", "X..X", ".XX.", "...X", "...X", "....",
                            ".XX.", "X...", "X...", ".XX.", "...X", "...X", ".XX.",
                            ".XX.", "X...", "X...", ".XX.", "X..X", "X..X", ".XX.",
                            ".XX.", "...X", "...X", "....", "...X", "...X", "....",
                            ".XX.", "X..X", "X..X", ".XX.", "X..X", "X..X", ".XX.",
                            ".XX.", "X..X", "X..X", ".XX.", "...X", "...X", ".XX."};

char tm[10][25];
char n[7][5];

int check(){
    for (int i=0; i<10; i++){
        bool flag = true;
        for (int j=0; j<7; j++){
            if (strcmp(n[j], num[i][j]) != 0){
                flag = false;
                break;
            }
        }
        if (flag){
            return i;
        }
    }
    return -1;
}

int main()
{
    int t;

    scanf("%d", &t);
    while (t > 0){
        t--;

        for (int i=0; i<7; i++) scanf("%s", tm[i]);

        int a, b, c, d;
        for (int i=0; i<7; i++){
            strncpy(n[i], tm[i], 4);
        }
        a = check();
        for (int i=0; i<7; i++){
            strncpy(n[i], tm[i]+5, 4);
        }
        b = check();
        for (int i=0; i<7; i++){
            strncpy(n[i], tm[i]+12, 4);
        }
        c = check();
        for (int i=0; i<7; i++){
            strncpy(n[i], tm[i]+17, 4);
        }
        d = check();
        printf("%d%d:%d%d\n", a,b,c,d);
    }
    return 0;
}


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值