HDU6210 transaction transaction transaction

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 279    Accepted Submission(s): 123


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is  ai   yuan  in  i t  city. Kelukin will take taxi, whose price is  1 yuan  per km and this fare cannot be ignored.
There are  n1  roads connecting  n  cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer  T  ( 1T10 ) , the number of test cases. 
For each test case:
first line contains an integer  n  ( 2n100000 ) means the number of cities;
second line contains  n  numbers, the  i th  number means the prices in  i th  city;  (1Price10000)  
then follows  n1  lines, each contains three numbers  x y  and  z  which means there exists a road between  x  and  y , the distance is  z km   (1z1000)
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
  
  
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
  
  
8
 

Source

——————————————————————————————————
题目的意思是给出一棵树,给出每个地点的买卖货物价格,和两个点之间的路费,求选出一个起点和一个终点,要求在起点买终点卖所得利润最大,求最大利润
思路:在原图基础上,建立一个源点和所有点连边,边权为每个点的价值,然后计算出源点到每个点的最短路,表示到这个点卖最少花费多少,然后遍历每个点算出获利求最大值
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const LL INF = 0x3f3f3f3f3f3f3f3f;

LL dis[100009],l[400009],w,a[100009];
int s[100009],nt[400009],e[400009],vis[100009];
int n,u,v;

struct node
{
    int id;
    LL dis;
    bool operator<(const node &a)const
    {
        return dis>a.dis;
    }
} pre,nt1;

void Dijkstra()
{
    memset(dis,INF,sizeof dis);
    memset(vis,0,sizeof vis);
    pre.id=pre.dis=0;
    dis[0]=0;
    priority_queue<node>q;
    q.push(pre);
    while(!q.empty())
    {
        pre=q.top();
        q.pop();
        vis[pre.id]=1;
        for(int i=s[pre.id]; ~i; i=nt[i])
        {
            if(vis[e[i]]) continue;
            if(dis[e[i]]>pre.dis+l[i])
            {
                dis[e[i]]=pre.dis+l[i];
                nt1.id=e[i],nt1.dis=dis[e[i]];
                q.push(nt1);
            }
        }
    }
    LL ans=0;
    for(int i=1; i<=n; i++)
    {
        LL temp=max(a[i]-dis[i],1LL*0);
        ans=max(ans,temp);
    }
    printf("%lld\n",ans);
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int cnt=0;
        memset(s,-1,sizeof s);
        for(int i=1; i<=n; i++)
        {
            scanf("%lld",&a[i]);
            nt[cnt]=s[i],s[i]=cnt,e[cnt]=0,l[cnt++]=a[i];
            nt[cnt]=s[0],s[0]=cnt,e[cnt]=i,l[cnt++]=a[i];
        }
        for(int i=1; i<n; i++)
        {
            scanf("%d%d%lld",&u,&v,&w);
            nt[cnt]=s[u],s[u]=cnt,e[cnt]=v,l[cnt++]=w;
            nt[cnt]=s[v],s[v]=cnt,e[cnt]=u,l[cnt++]=w;
        }
        Dijkstra();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值