HDU 6201 transaction transaction transaction &&沈阳网络赛1008

http://blog.csdn.net/a15110103117/article/details/77925858
参考了这篇博客
transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 374 Accepted Submission(s): 174

Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named “the Man Who Changed China”. Of course, Kelukin wouldn’t miss this chance to make money, but he doesn’t have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in it city. Kelukin will take taxi, whose price is 1yuan per km and this fare cannot be ignored.
There are n−1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.

Input
The first line contains an integer T (1≤T≤10) , the number of test cases.
For each test case:
first line contains an integer n (2≤n≤100000) means the number of cities;
second line contains n numbers, the ith number means the prices in ith city; (1≤Price≤10000)
then follows n−1 lines, each contains three numbers x, y and z which means there exists a road between x and y, the distance is zkm (1≤z≤1000).

Output
For each test case, output a single number in a line: the maximum money he can get.

Sample Input
1
4
10 40 15 30
1 2 30
1 3 2
3 4 10

Sample Output
8

Source
2017 ACM/ICPC Asia Regional Shenyang Online

题意:对于一个树,选择两个城市,一个城市买书,一个城市卖书,中间路程有花费,求最大的收益,这两个城市可以相同

思路:参考上面那篇博客,引入源点和汇点,就像一条河流,源点到每个点的权值都为该城市的书价,每个点到汇点的权值都为负的该城市的书价,对应买入和卖出,中间的花费也都为负,所以求源点到汇点的最长路就可以了,像是网络流

如图中这里写图片描述

代码如下:

#include<bits/stdc++.h>

using namespace std;
const int MAX_V = 100010;
const int INF = 0x3f3f3f3f;
int V;
struct Edge{
    int to;
    int cost;
}es;
vector<Edge> G[MAX_V];
int value[MAX_V],dis[MAX_V];
void add(int u,int v,int cost){
    es.to = v;
    es.cost = cost;
    G[u].push_back(es);
}
bool used[MAX_V];
void spfa(int a_){
    memset(dis,0,sizeof(dis));
    memset(used,false,sizeof(used));
    dis[0] = 0;
    queue<int> q;
    q.push(0);
    while(!q.empty()){
        int k = q.front();q.pop();
        used[k] = false;//出队列的点取消标记
        for(int i=0;i<G[k].size();i++){
            es = G[k][i];
            if(dis[es.to] < dis[k] + es.cost){//取更大的值
                dis[es.to] = dis[k] + es.cost;
                if(!used[es.to]){
                    used[es.to] = true;
                    q.push(es.to);
                }
            }
        }
    }
}
int main(void){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&V);
        for(int i=0;i<=V+1;i++)
            G[i].clear();
        for(int i=1;i<=V;i++){
            scanf("%d",&value[i]);
            add(0,i,value[i]);//源点,这里也可以为无向图
            add(i,V+1,-value[i]);//汇点
        }
        int x,y,z;
        for(int i=1;i<V;i++){
            scanf("%d %d %d",&x,&y,&z);
            add(x,y,-z);
            add(y,x,-z);
        }
        spfa(0);
        printf("%d\n",dis[V+1]);
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值