HDU 6201 transaction transaction transaction(好好好题)

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 2117    Accepted Submission(s): 973


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell. 
As we know, the price of this book was different in each city. It is  ai  yuan in  i t city. Kelukin will take taxi, whose price is  1 yuan per km and this fare cannot be ignored.
There are  n1 roads connecting  n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer  T ( 1T10) , the number of test cases. 
For each test case:
first line contains an integer  n ( 2n100000) means the number of cities;
second line contains  n numbers, the  i th number means the prices in  i th city;  (1Price10000) 
then follows  n1 lines, each contains three numbers  x y and  z which means there exists a road between  x and  y, the distance is  z km  (1z1000)
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
 
 
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
 
 
8
 

题目大意:一个人想从一个城市买书然后卖到另一个地方,每个地方的书的价钱都不同,而且相连的城市之间的路也有花费,问最多能赚多少钱。

建一个源点汇点,让每个城市与这个源点相连,权值为点权的负数,表示花费,每个城市再与这个汇点,权值为点权,表示赚取,每个城市再与相连的城市建边,权值为题目给出的边权的负数,然后在这个图上跑一遍最长路即可

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
const int maxn=1e5+7;
const int inf=-0x3f3f3f3f;
int head[maxn];
int price[maxn];
bool vis[maxn];
int dis[maxn];
int cnt,source,sink,n;
struct Node
{
    int to;
    int val;
    int next;
}edge[maxn<<3];
void init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
    return;
}
void add(int u,int v,int num)
{
    edge[cnt].to=v;
    edge[cnt].val=num;
    edge[cnt].next=head[u];
    head[u]=cnt++;
    return;
}
void spfa()
{
    queue<int> que;
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n+2;i++)
    {
        dis[i]=inf;
    }
    dis[source]=0;
    vis[source]=true;
    que.push(source);
    while(!que.empty())
    {
        int node=que.front();
        que.pop();
        vis[node]=false;
        for(int i=head[node];~i;i=edge[i].next)
        {
            int v=edge[i].to;
            if(dis[v]<dis[node]+edge[i].val)
            {
                dis[v]=dis[node]+edge[i].val;
                if(!vis[v])
                {
                    vis[v]=true;
                    que.push(v);
                }
            }
        }
    }
    return;
}
int main()
{
    int test;
    scanf("%d",&test);
    while(test--)
    {
        init();
        scanf("%d",&n);
        source=n+1;
        sink=n+2;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&price[i]);
            add(source,i,-price[i]);
            add(i,sink,price[i]);
        }
        for(int i=1;i<=n-1;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,-w);
            add(v,u,-w);
        }
        spfa();
        printf("%d\n",dis[sink]);;;;;;;
        //cout<<dis[sink]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值