解决创建maven工程时,产生“找不到插件的错误”

今天就来为大家解决一下我们在创建maven工程,pom.xml中一堆报错问题。

首先

问题:

按照以下步骤,进行排查,如果好了,就不用继续往下排查了

 第一步:

点击idea右侧的maven,然后找到刷新按钮,进行刷新,这时候,idea可能会自动下载插件,我们等待一下即可。

如果没有反应,第二步:

找到idea设置,因为,idea要自带一个maven,所以我们要设置为自己安装的maven,以及自己已经配置好了的settings.xml文件,本地仓库可以放在一个自己的目录。

 然后

这些红线上的要勾选起来。

这时候,重新加载一下maven工程或刷新,如果没有用,就看第三步。

第三步:

这时候,看看我们报错的位置,如果是<artifactId>标签报错了,那么你应该去检查一下你的<artifactId>上一个标签是不是<groupId>,如果不是,则要加上<groupId>标签,因为每个人可能插件的名称不一样,我找不到的插件是

maven-compiler-plugin

所以,我要在<artifactId>上面加上<groupId>org.apache.maven.plugins</groupId>,因为idea要根据groupId才能下载插件。

 

 如果加上标签后,还是报错,可能是因为你没有相应的依赖,这时候,你就要在

</dependencies>标签中插入一些依赖。

具体插入上面依赖呢?要根据你的插件名称,我找不到的插件名称为:

maven-assembly-plugin

所以,我在网上找了一个依赖。

<dependency>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-assembly-plugin</artifactId>
    <version>3.0.0</version>
</dependency>

 然后,在重新刷新一下,就可以了。

最后,如果还是依旧报错的话,可能是你安装的maven版本和idea版本不兼容,我建议去重新安装一个低版本的maven,我安装的是3.8.6版本,发现不兼容后,就换了一个3.6.1版本的maven。

最后发现可以了。


如果解决了,请在评论区扣个“666”

  • 10
    点赞
  • 11
    收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:1024 设计师:我叫白小胖 返回首页
评论 1

打赏作者

大数据阿嘉

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值