HDU 5791 Two

5 篇文章 0 订阅

Two

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.
 

Input
The input contains multiple test cases.

For each test case, the first line cantains two integers  N,M(1N,M1000) . The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.
 

Output
For each test case, output the answer mod 1000000007.
 

Sample Input
  
  
3 2 1 2 3 2 1 3 2 1 2 3 1 2
 

Sample Output
  
  
2 3
 
用矩阵模拟匹配过程,维护矩阵内元素的和
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
#define maxn 1010
#define ll long long
using namespace std;
const ll mod=1000000007;
ll n,m;
ll a[maxn],b[maxn];
ll dp[maxn][maxn];
ll dp2[maxn][maxn];
int main()
{
        while(scanf("%I64d %I64d",&n,&m)!=EOF)
        {
                memset(dp,0,sizeof(dp));
                memset(dp2,0,sizeof(dp2));
                for(int i=1;i<=n;i++)
                {
                        scanf("%I64d",&a[i]);
                }
                for(int i=1;i<=m;i++)
                {
                        scanf("%I64d",&b[i]);
                }
                for(int i=1;i<=m;i++)
                {
                        for(int j=1;j<=n;j++)
                        {
                                if(b[i]==a[j])
                                {
                                        dp[i][j]=(1+dp2[i-1][j-1])%mod;
                                        dp2[i][j]=(dp2[i][j-1]+dp2[i-1][j]-dp2[i-1][j-1]+dp[i][j]+mod)%mod;//注意要加一个mod
                                }
                                else
                                {
                                        dp2[i][j]=(dp2[i][j-1]+dp2[i-1][j]-dp2[i-1][j-1]+mod)%mod;//注意要加上一个mod
                                }
                        }
                }
                ll ans=0ll;
                for(int i=1;i<=m;i++)
                {
                        for(int j=1;j<=n;j++)
                        {
                                //cout<<dp[i][j]<<" ";
                                ans=(ans+dp[i][j])%mod;
                        }
                        //cout<<endl;
                }
                printf("%lld\n",ans%mod);
        }
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值