HDU_5791_Two(简单dp)

Two

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1051    Accepted Submission(s): 489


Problem Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.
 

Input
The input contains multiple test cases.

For each test case, the first line cantains two integers N,M(1N,M1000) . The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.
 

Output
For each test case, output the answer mod 1000000007.
 

Sample Input
  
  
3 2 1 2 3 2 1 3 2 1 2 3 1 2
 

Sample Output
  
  
2 3
 

Author
ZSTU
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5792  5790  5789  5788  5787 

题意

给你两个数串

问你两个数串有多少子串一致

子串不一定是连续的


解题思路

首先这个问题要想到是个dp问题

dp[i][j]代表第一个串到I位第二个串到j位相同子串的个数

则dp[i][j]=dp[i-1][j]+dp[i][j-1]-dp[I-1][j-1]减掉多的部分

但是末尾如果匹配的话

那么只要加上都减掉末尾的匹配数量再加1就可以了

因为这些子串都可以加上末尾这个元素构成新的匹配,而末尾的匹配自身也构成1个答案



#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

typedef unsigned long long LL;
const int M=1005;
const int MO=1e9+7;
LL dp[M][M];
//dp[i][j] 第一个串到i位置第二个串到j位置相同的前缀个数

int nu1[M],nu2[M];

int main()
{
    //freopen("1.in","r",stdin);
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&nu1[i]);
        for(int i=1;i<=m;i++)
            scanf("%d",&nu2[i]);
        memset(dp,0,sizeof(dp));
        //for(int i=1;i<M;i++)
        //    dp[i][0]=dp[0][i]=1;//初始化全部置零就可以了
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                dp[i][j]=(dp[i-1][j]+dp[i][j-1]-dp[i-1][j-1]+MO)%MO;
                if(nu1[i]==nu2[j])
                    dp[i][j]=(dp[i][j]+dp[i-1][j-1]+1)%MO;
            }
        }
        //for(int i=1;i<=n;i++)
        //{
        //    for(int j=1;j<=m;j++)
        //        cout<<dp[i][j]<<" ";
        //    cout<<endl;
        //}

        printf("%I64d\n",dp[n][m]%MO);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值