04-树3. Root of AVL Tree (25)

04-树3. Root of AVL Tree (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    

    

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print ythe root of the resulting AVL tree in one line.

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88

输出平衡二叉树的根节点,难点是二叉树的旋转处理。网查大侠方法,然后就慢慢悟了。。。

#include<iostream>
using namespace std;

struct AVLTreeNode{
	int Data;
	AVLTreeNode *Left;
	AVLTreeNode *Right;
	int Height;
};

int GetHeight(AVLTreeNode *tree)  			  // 获取树高 
{
	if(tree == NULL)
		return -1;
	else
		return tree->Height;
}                                                             

int Max(int a,int b)
{
	return (a>b)?a:b;
}

AVLTreeNode *SingleLeftRotation(AVLTreeNode *A)			//单向左旋 
{
	AVLTreeNode *B=A->Left;
	A->Left=B->Right;
	B->Right=A;
	A->Height=Max(GetHeight(A->Left),GetHeight(A->Right))+1;
	B->Height=Max(GetHeight(B->Left),A->Height)+1;
	return B;
}

AVLTreeNode *SingleRightRotation(AVLTreeNode *A)		//单向右旋 
{
	AVLTreeNode *B=A->Right;
	A->Right=B->Left;
	B->Left=A;
	A->Height=Max(GetHeight(A->Left),GetHeight(A->Right))+1;
	B->Height=Max(GetHeight(B->Left),A->Height)+1;
	return B;
}

AVLTreeNode *DoubleLeftRightRotation(AVLTreeNode *A)	//左右双旋 
{
	A->Left=SingleRightRotation(A->Left);
	return SingleLeftRotation(A);
}

AVLTreeNode *DoubleRightLeftRotation(AVLTreeNode *A)	//右左双旋 
{
	A->Right=SingleLeftRotation(A->Right);
	return SingleRightRotation(A);
}

AVLTreeNode *AVL_Insertion ( int X, AVLTreeNode *T )	//将元素插入AVL树中并做旋转处理 
{ 
	if ( !T ) 
	{
		T = new AVLTreeNode;
		T->Data = X;
		T->Height = 0;
		T->Left = T->Right = NULL;
	} 
	else if (X < T->Data) 
	{ 
		T->Left = AVL_Insertion(X, T->Left);
		if (GetHeight(T->Left) - GetHeight(T->Right) == 2 )
			if (X < T->Left->Data)
				T = SingleLeftRotation(T);
			else
				T = DoubleLeftRightRotation(T);
	} 
	else if (X > T->Data) 
	{ 
		T->Right = AVL_Insertion(X, T->Right);
		if (GetHeight(T->Left) - GetHeight(T->Right) == -2 )
			if (X > T->Right->Data)
				T = SingleRightRotation(T); 
			else
				T = DoubleRightLeftRotation(T);
	} 
	T->Height = Max(GetHeight(T->Left),GetHeight(T->Right))+1;
	return T;
}

int main()
{
	int i,n,TestNum;
	AVLTreeNode *root =NULL;
	cin>>TestNum;
	for(i=0;i<TestNum;i++){
		cin>>n;
		root = AVL_Insertion(n,root);
	}
	cout<<root->Data;
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值