The Suspects --并查集水题

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1

1

分析:并查集很水的一道题。。就是从0开始根据学生所在的组织进行合并就好了,然后累加每个集合的值。

上代码:

#include <cstdio>  
#include <cstring>  
#include <algorithm>  
#define maxn 33000  
using namespace std;  
  
int per[maxn], num[maxn], n, m;  
int a[maxn];  
  
void init(){  
    for(int i = 0; i < n ; ++i){  
        per[i] = i;  
        num[i] = 1;//一开始每个父节点所在的集合只有一个人
    }  
    return ;  
}  
  
int find(int x){  
    if(x == per[x])  
        return x;  
    return per[x] = find(per[x]);  
}  
  
void join(int x, int y){  
    int fx = find(x);  
    int fy = find(y);  
    if(fx != fy){  
        per[fx] = fy;  
        num[fy] += num[fx];//将子节点纳入父节点  
    }  
    return ;  
}  
  
int main (){  
    while(scanf("%d%d", &n, &m), n || m){  
            init();  
        while(m--){  
            int t;  
            scanf("%d", &t);  
            for(int i = 0; i < t; ++i){  
                scanf("%d", &a[i]);  
            }  
            for(int i = 0 ; i < t - 1; ++i)  
                join(a[i], a[i + 1]);  
        }  
        int  k = find(0);  //0号开始是嫌疑人
        printf("%d\n", num[k]);//最后父节点的集合总人数即总的人数  
    }  
    return 0;  
}  

实在是很水,没什么好说的,差不多模板题吧。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值