数学1(n^n)Leftmost Digit

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3677 Accepted Submission(s): 1631
 
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2
 
     
思路:
对于任何一个num 都有 a*10^n;(科学计数)
一个数的最左边的数就是a的整数部分。
所以num^num=a*10^n 开 log得num*lg(num)=lg(a)+n,这里a由于小于10,lg(a)小于1,是小数;
令x=lg(a)+n; 那么 a=10^(x-n),因为lg(a)小数,所以n=int(x),
所以 a=10^(x-int(x)).
然后a 取整就好了。
参考代码:
 
    
#if 1
#include<bits/stdc++.h>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
   {	
	double x,a, n;
	scanf("%lf",&n);
	x=n*log10(n);
	a=pow(10.0,x-(__int64)x);
   	
	int end=int(a);
printf("%d\n",end);
   }
} 
#endif 


//强大的数学

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值