Pie

Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:<ul><li>One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.<li>One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.</ul>
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10<sup>3</sup>.
 

Sample Input
  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
  
  
25.1327 3.1416 50.2655
这个题当时当作例题上课讲的,给你n个蛋糕,给你这些蛋糕的半径,问你 每个人 分一块(蛋糕不能重新组合),最多能分多少? 
整个蛋糕由sum这么多,让left=0,right=sum, 然后二分,求出能分出的蛋糕的数量,拿来和人数比较,这样一直调整区间继续分。 

//扩大10的六次方倍,精准度 
#if 0
#include<iostream>
#include<iomanip>
using namespace std;
long long a[10010];       
int n,p;           
const double pai=3.14159265358979;

bool fun(long long x)              
{
	long long sum=0;
	for(int i=0; i<n; i++)
	{
		sum+=a[i]/x; 
	}
	
	if(sum>=p)
	{
		return 1;
	}
	else
		return 0;
}

int main() 
{
	int T;
	cin>>T;
	
	while(T--)
	{
		
		cin>>n>>p;
		p+=1; 
		long long l=0,r=0,mid,res=0;
		for(int i=0; i<n; i++)
		{
			int x;
			cin>>x;
			a[i]=pai*x*x*1000000; //5 
			r+=a[i]; 
		}
		
	
		while(r>=l)
		{
			mid=(l+r)/2;
			
			if(fun(mid)) //分多了 
			{
				l=mid+1;
				res=mid;
			}
			else
			{
				r=mid-1;	
			} 
		}
		
		cout<<fixed<<setprecision(4)<<res/1000000.0<<endl;
	}
}

#endif








  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值