1800 Flying to the Mars 大数 最多不上升序列 简化题意

 Flying to the Mars

          Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                Total Submission(s): 4318    Accepted Submission(s): 1393


Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.
 

Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
4
10
20
30
04
5
2
3
4
3
4
 

Sample Output
1
2
#include "stdio.h"

/*
 这题就是一道简单的最大子序列问题
 或者所是找出所有所有不上升子序列的问题
 但是数很大,会超时,
 以下方法是在数据不大的情况下可以使用的。
 


 */
//继续往后看,第二份代码是能够处理大数的


typedef struct{
    int value;
    int flag//代表是否被选过,1没选过,0选过
}NUM;


void sort(NUM num[],int n){//从大到小排序
    
    for(int i=0;i<n;i++)
        for(int j=i;j<n;j++){
            if(num[i].value<num[j].value){
                int temp=num[i].value;
                num[i].value=num[j].value;
                num[j].value=temp;
            }
        }
}


int main(){
    
    
    freopen("/Users/qigelaodadehongxiaodi/Desktop/data1.txt", "r", stdin);
    //这个不理,是用来方便输入输出的东西,利用文本输入流来读取数据
    //提交代码的时候记得注销这条语句
    
    int n,max=0;
    NUM num[1000];
    int cnt=0,cntnum=0,total=0;
    
    while(scanf("%d",&n)!=EOF){
        
        for(int i=0;i<n;i++){
            scanf("%d",&num[i].value);
            num[i].flag=1;
        }
        
        sort(num,n);
        
        while(cnt!=n){
            while(max==0){
                if(num[cntnum].flag==1){
                    max=num[cntnum].value;
                    cnt++;
                    break;
                }else{
                    cntnum++;
                }
            }// 如果重新开始,则让首个没选过的当max
            
            if(num[cntnum].flag!=0&&max>num[cntnum].value){
                max=num[cntnum].value;
                cnt++;
                if(cnt==n){//注意这个,假如cnt==n,但是不是最后一项,则total不会++,
                    //因此自己定了一个退出机制
                    total++;
                    break;
                }
                cntnum++;
            }else{
                cntnum++;
            }
            if(cntnum==n){
                total++;
                cntnum=0;
                max=0;
            }
            
        }
        
        printf("%d\n",total);
           
    }
    
    return 0;
    
}






________________托马斯爆炸帅的分割线————————————————————————


#include "iostream"
#include <cstdio>
#include "algorithm"
#include <cstring>

/*
 这份代码的思路是更简化题意,即题意是找出重复次数最多的数的重复次数
 */

using namespace std;
int a[3002];
bool cmp(int a,int b){
    return a>b;
}

int main(){
    
    
    freopen("/Users/qigelaodadehongxiaodi/Desktop/data1.txt", "r", stdin);
    //这个不理,是用来方便输入输出的东西,利用文本输入流来读取数据
    //提交代码的时候记得注销这条语句
    
    int n,j,tot,k;
    while(~scanf("%d",&n)){
        k=1;
        tot=0;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n,cmp);
        
        for(int i=1;i<n;i++){
            if(a[i]==a[i-1])
                k++;
            else{
                if(tot<k)
                    tot=k;
                k=1;
            }
        }
        
        if(k>tot)
            tot=k;
        printf("%d\n",tot);
    }
    
    
    
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值