HDU1800Flying to the Mars(字典树)

题目:



Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
 

Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
  
  
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
  
  
1 2
 

题解:找到重复次数最多的数,求出它的重复次数。如第二个例子2,3,4,3,4,重复最多的数是3与4,它们都重复了三次,则最终求出来的最大重复次数是2;

把每个数的按字符存放到树中,如数10,可以看成字符‘10’,‘1’就存放到根节点的第二个子树,而‘0’就存放到第二个子树的第一个子树中,最终第二个子树的第一个子树结点中,数据部分count+1;

注意:01与001在字典树中是不同的,所以要先把前面没用的0去除;

错误分析:创建结点时把T写成Tri根节点了,导致每加入一个数都从头开始;


#include<stdio.h>
#include<cstring>
#include<stdlib.h>
#include<iostream>
using namespace std;
#pragma comment(linker,"/STACK:102400000,102400000")
#define MAX   10
char a[35];
int ans;
struct Tritree   //存储结构
{
     int count;     //标记共同前缀的单词数
     Tritree *next[MAX];   //单个字符的可能取值
}*Tri;
Tritree * build_tri()  //创建节点
{
     Tritree *T=(Tritree *)malloc(sizeof(Tritree));
     T->count=0;
     for(int i=0;i<MAX;i++)
          T->next[i]=NULL;
     return T;
}
void insert_tri(char a[])   //把每个字符串插入字典树中
{
     Tritree *p=Tri;
     for(int i=0;i<strlen(a);i++)
     {
          int id=a[i]-'0';    //取a的第i个字符,注意题目中只有数字字符
          if(p->next[id]==NULL)
               p->next[id]=build_tri();
          p=p->next[id]; 
     }
     p->count++;
     ans=max(ans,p->count);

}
void  delete_tri(Tritree *T)//释放字典树
{
     if(T!=NULL)
     {
          for(int i=0;i<MAX;i++)
          {
               if(T->next[i]!=NULL)
                    delete_tri(T->next[i]);
          }

     }
     free(T);
     T=NULL;
}

int main()
{
   int n;
   while(scanf("%d",&n)!=EOF)
   {
        ans=0;
        Tri=build_tri();
        for(int i=0;i<n;i++)
        {
             scanf("%s",a);
             int j=0;
             while(a[j]=='0')j++;      //去除数前面的无用‘0’
             insert_tri(a+j);
        }

          printf("%d\n",ans);
          delete_tri(Tri);
   }
   return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值