[POJ - 3041] Asteroids(二分图)

5 篇文章 0 订阅
3 篇文章 0 订阅

Link:http://poj.org/problem?id=3041


Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23415 Accepted: 12712

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source



题意:

给出N*N的矩阵,有的位置有行星。已知一枪可以击溃一行或一列上的所有行星。问最少几枪可以击溃所有行星。


思路:

以行为X集合,列为Y集合。一个行星在(X,Y),则从X向Y可以连成边,则只要选择一个顶点,与之相连的所有顶点都会被选。此题则是求最小顶点覆盖数。


*最小顶点覆盖数:

假如选择了一个顶点就相当于覆盖了以它为端点的所有边,选择最少的点覆盖所有边


*Konig定理:

一个二分图中的最大匹配数等于它的最小顶点覆盖数


So这题就是变相地求二分图的最大匹配数


Code:

#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
using namespace std;
int n,k;
int f[505];
bool vis[505];
bool fr[505][505];
int find(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(fr[x][i]&&!vis[i])
		{
			vis[i]=true;
			if(f[i]==-1)
			{
				f[i]=x;
				return true;
			}
			else if(find(f[i]))
			{
				f[i]=x;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		memset(f,-1,sizeof(f));
		memset(fr,false,sizeof(fr));
		for(int i=1;i<=k;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			fr[x][y]=true;
		}
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			memset(vis,false,sizeof(vis));
			if(find(i))
				ans++;
		}
		printf("%d\n",ans);
	}
return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值