Round 1 F - Rikka with Parenthesis II HDU - 5831-括号匹配

题目链接:
https://vjudge.net/contest/168327#problem/F

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string “” is a correct sequence.
2.If “X” and “Y” are correct sequences, then “XY” (the concatenation of X and Y) is a correct sequence.
3.If “X” is a correct sequence, then “(X)” is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include “”, “()”, “()()()”, “(()())”, and “(((())))”.

Now Yuta has a parentheses sequence SS, and he wants Rikka to choose two different position i,ji,j and swap Si,SjSi,Sj.

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?
Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
Output
For each testcase, print “Yes” or “No” in a line.
Sample Input
3
4
())(
4
()()
6
)))(((
Sample Output
Yes
Yes
No

Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.

大意:
括号匹配 进阶版,必须交换一次位置。

法一,开数组记录

#include<bits/stdc++.h>
#define mem(s,t) memset(s,t,sizeof(s))
typedef long long ll;
using namespace std;
//#define LOCAL
const int MAXN =100000+10;
int op[MAXN];
int main(){
#ifdef LOCAL
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
#endif
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        char s[MAXN];
        mem(s,0);
        mem(op,0);
        scanf("%s",s+1);

        for(int i=1;i<=n;i++){
            if(s[i]=='(')
                op[i]=op[i-1]+1;
            else op[i]=op[i-1]-1;
        }
        if(op[n]!=0){
            puts("No");
            continue;
        }
        if(n%2){
            puts("No");
            continue;
        }
        if(strcmp(s+1,"()")==0){
            puts("No");
            continue;
        }
        int bad=0;
        for(int i=1;i<=n;i++){
            if(op[i]<-2)
                bad=1;
        }
        if(bad) puts("No");
        else puts("Yes");
    }
    return 0;
}

法二,栈

#include<bits/stdc++.h>
#define mem(s,t) memset(s,t,sizeof(s))
typedef long long ll;
using namespace std;
//#define LOCAL
const int MAXN =100000+10;
stack<char> st;
char s[MAXN];
int n;
bool solve(){
    while(!st.empty()) st.pop();
    st.push(s[1]);
    for(int i=2;i<=n;i++){
        if(!st.empty() && st.top()=='(' && s[i]==')')
            st.pop();
        else st.push(s[i]);
    }
    if(st.size()>4) return 0;
    return 1;
}
int main(){
#ifdef LOCAL
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
#endif
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        mem(s,0);
        scanf("%s",s+1);
        if(n&1) puts("No");
        else if(strcmp(s+1,"()")==0) puts("No");
        else if(solve()) puts("Yes");
        else puts("No");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值