HDU 5831 Rikka with Parenthesis II 2016 Multi-University Training Contest 8

Rikka with Parenthesis II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 545 Accepted Submission(s): 314

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string “” is a correct sequence.
2.If “X” and “Y” are correct sequences, then “XY” (the concatenation of X and Y) is a correct sequence.
3.If “X” is a correct sequence, then “(X)” is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include “”, “()”, “()()()”, “(()())”, and “(((())))”.

Now Yuta has a parentheses sequence S, and he wants Rikka to choose two different position i,j and swap Si,Sj.

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?

Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.

Output
For each testcase, print “Yes” or “No” in a line.

Sample Input
3
4
())(
4
()()
6
)))(((

Sample Output
Yes
Yes
No

Hint

For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.

Author
学军中学

Source
2016 Multi-University Training Contest 8

Recommend
wange2014 | We have carefully selected several similar problems for you: 5831 5830 5829 5828 5827

题意:有好多(和),问必须调换其中一对的位置,能不能使所有的括号都两两匹配。
又是中学生出的乱搞题。。不想解释了。

#include "cstring"
#include "cstdio"
#include "iostream"
#include "string.h"
using namespace std;
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        int n;
        scanf("%d",&n);
        int l=0,r=0;
        char now[100005];
        scanf("%s",now+1);
        int flag=0;
        int pair=0;
        if(n==2&&now[1]=='('&&now[2]==')')
        {
            printf("No\n");
            continue;
        }
        if(n==2&&now[1]==')'&&now[2]=='(')
        {
            printf("Yes\n");
            continue;
        }

        for(int i=1;i<=n;i++)
        {
            if(now[i]=='(')
                l++;
            else
                r++;
            if(r-l<=2)
            {

            }
            else
                flag=1;
        }

        for(int i=1;i<=n;i++)
        {
            if(now[i]==')'&&l>0)
            {
                l--;
                r--;
            }
        }

        if(l==0&r==0&&flag==0)
        {
            printf("Yes\n");
            continue;
        }
        if(l==1&&r==1&&flag==0)
        {
            printf("Yes\n");
            continue;
        }
        printf("No\n");

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值