Round 3 D - Balance POJ - 1837 -树形DP

原题链接:
http://poj.org/problem?id=1837

大意:
一个天平,已知钩子坐标和重物重量,且重物都要用上,求让天平平衡的方法数。

思路:
树形DP,讲每个重物的力矩算出来并求和建树。
以样例为例:

Sample Input
2 4
-2 3
3 4 5 8
Sample Output
2

这里写图片描述

数最后有多少 0 即可。代码实现时可以用最后一个力矩取负值来查找 取代数几个0 的方法。


#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<set>
#include<map>
using namespace std;
#define D(v) cout<<#v<<" "<<v<<endl
#define mem(s,t) memset(s,t,sizeof(s))
const int MAXN =25;
int C,G;
int c[MAXN],g[MAXN];
set<int> s,S;
map<int,int> m,M;
typedef set<int>::iterator It;
int main(){
    cin>>C>>G;
    for(int i=0;i<C;i++){
        cin>>c[i];
    }
    for(int j=0;j<G;j++){
        cin>>g[j];
    }
    M[0]=1;
    for(int i=0;i<G-1;i++){
        m=M;
        s=S;
        M.clear();
        S.clear();
        s.insert(0);
        for(int j=0;j<C;j++){
            int val =g[i]*c[j];
            for(It it=s.begin();it!=s.end();it++){
                //D(*it);
                S.insert(*it+val);
                M[*it+val] += m[*it];
            }
        }
    }
    int cnt=0;
    int Ans=0;
    for(int i=0;i<C;i++){
        Ans=c[i]*g[G-1];
        cnt+=M[-Ans];
    }
    cout<<cnt<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值