UVA - 1664 Conquer a New Region

1664 Conquer a New Region
The wheel of the history rolling forward, our king conquered a new region in a distant continent.
There are N towns (numbered from 1 to N) in this region connected by several roads. It’s confirmed
that there is exact one route between any two towns. Traffic is important while controlled colonies are
far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to
transport at most C(i, j) goods between town i and town j if there is a road between them. And for a
route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and
j which is equal to the minimum capacity of the roads on the route.
Our king wants to select a center town to restore his war-resources in which the total traffic capacities
from the center to the other N −1 towns is maximized. Now, you, the best programmer in the kingdom,
should help our king to select this center.
Input
There are multiple test cases.
The first line of each case contains an integer N. (1 ≤ N ≤ 200, 000)
The next N − 1 lines each contains three integers a, b, c indicating there is a road between town a
and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100, 000)
Output
For each test case, output an integer indicating the total traffic capacity of the chosen center town.
Sample Input
4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1
Sample Output
4

3


今儿做着一道神奇的并查集的题目哈~ 大意是这样的 n个城市 每两个城市之间有通路 可视为权值c 定义一个s 为i到j唯一道路上权值的最小值 找一个中心城市使得它到其他所有点的s值之和最大。用并查集,将边排序后按照权值从大到小的顺序添加,但是要判断是将哪个点作为那个中心城市

#include <bits/stdc++.h>
using namespace std;
const int maxn = 200005;
int n;
long long g[maxn],f[maxn],s[maxn];
int Find(int x){
    return x==f[x]?x:f[x]=Find(f[x]);
}
int main(){
    while(~scanf("%d",&n)){
        pair<long long, pair<long long,long long > > e[maxn];
        for(int i=1;i<=n;i++)
            f[i]=i,s[i]=1,g[i]=0;
        for(int i=1;i<n;i++)
            scanf("%lld%lld%lld",&e[i].second.first,&e[i].second.second,&e[i].first);
        sort(e+1,e+n);
        for(int i=n-1;i>=1;i--){
            long long x=Find(e[i].second.first),y=Find(e[i].second.second),z=e[i].first;
            if(g[x]+z*s[y]<g[y]+z*s[x])
                f[x]=y,g[y]+=z*s[x],s[y]+=s[x];
            else
                f[y]=x,g[x]+=z*s[y],s[x]+=s[y];
        }
        printf("%lld\n",g[Find(1)]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值