甲级PAT 1070 Mooncake (排序+贪心)

1070 Mooncake (25 分)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

题目要求 :

给定所有种类的月饼的库存量,总售价,以及市场最大的销售量。在不超过市场最大销售量的情况下如何售卖获取最大利润,结果保留两位小数。

解题思路:

算出每类月饼的单价,按从大到小排序,每次选取单价最大的直到达到最大销售量

注意:

月饼的库存量以及最大销售量一定要用浮点数存储。虽然题目给的是整数,但是如果用整数存储第三个测试点始终通不过。

完整代码:

#include<bits/stdc++.h>
using namespace std;

struct Mooncake{
	double amount;
	double price;
	double perpro;	
	
}mooncake[1001];

bool comp(Mooncake m1,Mooncake m2){
	return m1.perpro>m2.perpro;
}

int main(){
	int N,i;
	double profit=0.0,D;
	scanf("%d%lf",&N,&D);
	for(i=0;i<N;i++){
		scanf("%lf",&mooncake[i].amount);
	}
	for(i=0;i<N;i++){
		scanf("%lf",&mooncake[i].price);
		mooncake[i].perpro = float(mooncake[i].price)/mooncake[i].amount;			
	}
	sort(mooncake,mooncake+N,comp);
	for(i=0;i<N;i++){
		if(mooncake[i].amount <=D){
			profit+=mooncake[i].price;
			D-=mooncake[i].amount;
		}else{
			profit+=D*mooncake[i].perpro;
			break;
		}
	}
	printf("%.2f",profit);	
	return 0;
} 

代码简洁

2019.2.8

#include<bits/stdc++.h>
using namespace std;

struct Cake{
	double price,amount,perprice;
};
bool com(Cake c1,Cake c2){
	return c1.perprice>c2.perprice;
}

int main(){
	int n,i;
	double d,total=0,temp=0;
	Cake cake[1010];
	scanf("%d %lf",&n,&d);
	for(i=0;i<n;i++) scanf("%lf",&cake[i].amount);
	for(i=0;i<n;i++){
		scanf("%lf",&cake[i].price);
		cake[i].perprice=cake[i].price/cake[i].amount;
	}
	sort(cake,cake+n,com);
	for(i=0;i<n;i++){
		if(temp+cake[i].amount<=d){
			total+=cake[i].price;
			temp+=cake[i].amount;
		}else{
			total+=cake[i].perprice*(d-temp);
			temp=d;
		}
		if(temp>=d) break;
	}
	printf("%.2f",total);
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
import java.io.BufferedReader; import java.io.IOException; import java.io.InputStreamReader; import java.util.ArrayList; import java.util.Arrays; import java.util.Collection; import java.util.Collections; import java.util.LinkedList; import java.util.List; import java.util.Scanner; public class Main{ public static void main(String[] args) throws IOException { BufferedReader in=new BufferedReader(new InputStreamReader(System.in)); int n; double need; double sum=0; String s[]=in.readLine().split(" "); n=Integer.parseInt(s[0]); need=Double.parseDouble(s[1]); String amount[]=in.readLine().split(" "); String price[]=in.readLine().split(" "); ArrayList<Mooncake> cakes=new ArrayList<Mooncake>(); for(int i=0;i<n;i++){ Mooncake cake=new Mooncake(); cake.setAmount(Double.parseDouble(amount[i])); cake.setSales(Double.parseDouble(price[i])); cake.setValues(Double.parseDouble(price[i])/Double.parseDouble(amount[i])); cakes.add(cake); } Collections.sort(cakes); for(Mooncake c: cakes){ if(need>=c.amount){ need=need-c.amount; sum+=c.amount*c.values; } else{ sum+=need*c.values; need=0; } if(need==0){ break; } } System.out.printf("%.2f",sum); } static class Mooncake implements Comparable<Mooncake>{ double amount; double sales; double values; public double getAmount() { return amount; } public void setAmount(double amount) { this.amount = amount; } public double getSales() { return sales; } public void setSales(double sales) { this.sales = sales; } public double getValues() { return values; } public void setValues(double values) { this.values = values; } @Override public int compareTo(Mooncake arg0) { // TODO Auto-generated method stub return this.values>arg0.values?-1:1; } } }转c++
05-23
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值