甲级PAT 1067 Sort with Swap(0, i) (贪心)

1067 Sort with Swap(0, i) (25 分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

题目要求 

不断交换0和任意数值的位置,将一个无序的数列变成有序,按0,1,2,3……,n这样,问 最少的交换次数是多少

解题思路

最少的交换次数一定是尽量每一交换都至少将一个位置变得有序,这是最快的。

用a[i]来存储元素i所在数列中的位置。这样a[a[i]]就可以表示元素i对应的位置a[i]对应的位置

例如

5 4 3 2 1 0

a[0]=5

a[a[0]]=a[5]=0

如果0不在0的位置上,将0所在位置a[0]和0所占位置对应值所在位置a[a[0]]依次进行交换。会出现0在0位置上,但是数列现在还并非有序。这是需要将0再随便和一个无序元素进行交换,再按照之前的交换策略。

在编程的时候,随便和一个无序的元素进行交换这个过程可以通过遍历进行,从1开始,如果1并非在有序的位置上,则将0不断进行交换,直到0在数列0的位置上,如果此时1还是无序,则将1和0的位置进行交换。省略了每次交换后都得判断数列是否全部有序的过程。

完整代码

#include<bits/stdc++.h>
using namespace std;
int a[100010];

int main(){
	int n,i,t,num=0;
	cin>>n;
	for(i=0;i<n;i++){
		cin>>t;
		a[t]=i;
	}
	for(i=1;i<n;i++){
		if(i!=a[i]){
			while(a[0]!=0){
				swap(a[0],a[a[0]]);
				num++;
			}
			if(i!=a[i]){
				swap(a[0],a[i]);
				num++;
			}
		}
	}
	cout<<num<<endl;
	return 0;
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值