PAT甲级1067 Sort with Swap(0, i)//贪心算法

Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤105​​ ) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

思路

注意一下几点:

  • 题目说明了数列是从0开始的,以1为公差的等差数列
  • 每次只能用0和其他几个数交换

所以可以每次将数组0号位的数换到他应该在的地方。比如arr[0] = 3,就将arr[0]和arr[3]进行交换,再把3号位的数换到arr[0],然后继续执行这个操作直到序列成为顺序。

但是不能忽略一个问题,如果0归位了怎么办,也就是说0在arr[0]处。这时候可以让0和一个还没归位的数交换(这里如果让0和已归位的数进行交换,则以后还要让他和0进行交换,这样会徒增交换次数),然后继续执行上面的归位操作。但是该怎么找未归位的数呢?个人感觉这个问题才是该题目的核心难点——需要一个好算法来快速的找到未归位的数,然后和0进行交换。如果这个算法时间复杂度太高,最后的测试点就会超时。

我的方法是用一个容器装入那些未归位的数,一旦这个数归位,就将他踢出容器。每当0归位了,就直接在容器中拿出一个数和0进行交换。我选择map作为这个容器,因为踢出一个数十分方便快捷。
代码实现如下:

#include <iostream>
#include <cstdlib>
#include <vector>
#include <map>
using namespace std;
void swap(int &a, int &b);
int ans = 0;
int main()
{
	int n;
	cin >> n;
	vector<int> vec(n);
	map<int, bool> pos;
	int cnt = 0;
	for (int i = 0; i < n; i++)
	{
		cin >> vec[i];
		if (vec[i] != i)
			pos[i] = false; //相当于将这个数装入容器
	}
	while (pos.size() > 1)
	{
		if (vec[0] == 0) //如果0归位了
		{
			map<int, bool>::iterator it = pos.begin();
			//因为map自动实现按键值排序,所以pos.begin()一定是0
			//所以这里让it++,意思是it往后找一个
			//while的循环条件是pos.size() > 1的原因也是因为pos中一定有一个0
			//因为0一定是最后一个归位的
			it++;
			int tmp = it->first;
			swap(vec[0], vec[tmp]);
		}
		else
		{
			while (vec[0] != 0)
			{
				//马上要执行归位操作了,这里就直接把这个数踢出容器
				map<int, bool>::iterator it = pos.find(vec[0]);
				pos.erase(it);
				//执行归位
				swap(vec[0], vec[vec[0]]);
			}
		}
	}
	cout << ans << endl;
	system("pause");
	return 0;
}
void swap(int &a, int &b)
{
	int tmp = a;
	a = b;
	b = tmp;
	ans++;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值