1085 Perfect Sequence (25 分)
Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109.
Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
题目要求
一个序列,其中最大值max,最小值min,对于一个长度为n的序列,给定p,找到最长的子序列满足max<=min*p
解题思路
肯定是先对序列按从小到大进行排序,这里有两个变量,min和max都是变化的,如果用两个for循环对每个子序列进行判断需要10^10次运算,所以采用二分查找的方式,以序列中的每个数作为最小的值i(0到n-1),找到满足条件的最大值m所对应的序列元素个数m-i+1
注意
a[i]*p乘积要强制转换为long long,否则最后一个点报错
完整代码
#include<bits/stdc++.h>
using namespace std;
int main(){
int n,p,i,l,m,r,maxn=0;
int a[100010];
cin>>n>>p;
for(i=0;i<n;i++) cin>>a[i];
sort(a,a+n);
for(i=0;i<n;i++){
l=i;
r=n-1;
while(l<=r){
m=(l+r)/2;
if(a[m]<=a[i]*p){
maxn=max(maxn,m-i+1);
l=m+1;
}else r=m-1;
}
}
cout<<maxn;
return 0;
}