甲级PAT 1151 LCA in a Binary Tree (30 分)(LCA)

1151 LCA in a Binary Tree (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目要求 

根据一棵二叉树的中序遍历和前序遍历构建一棵二叉树,然后找到给定两个节点的最近公共祖先,按题目要求输出

有四种格式

1.要查找的两个结点都不在树中,输出ERROR: 12 and -3 are not found.

2.要查找的其中一个结点不在树中,输出ERROR: 0 is not found.

3.查找的结点存在,也有祖先,但是祖先是两个结点其中的一个,输出8 is an ancestor of 7.

4.一般情况,输出8 is an ancestor of 7.

解题思路

这题和1143题很像,不过1143题是一棵BST,中序是按大小顺序排序的。这里就是一棵普通的二叉树,但是其找到最近公共祖先的方法还是一样的,如果两个结点在一个根结点的两边,则这个根结点就是它的最近公共祖先,如果两个结点在根结点的左边,向左子树接着找,如果两个结点在根结点的右边,则向右子树接着找。如果其中一个结点就是根结点,则这个根结点就是另一个结点的祖先。

这里主要就是如何判断两个结点和根结点的位置情况,只要判断中序遍历的下标,如果两个结点的下标在中序遍历中根结点所在下标的左右,即可认为它们在根结点的两边。因为中序遍历,通过一根结点可以判断左子树和右子树。利用map<int,int>保存下标。

注意

1.必须要用map<int,int> pos来保存下标信息,因为如果用int数组,还要判断存在不存在的时候,如果输入-1或者-999就会发生错误。

2.由于0表示不存在,所以输入中序遍历的下标从1开始

3.在根据前序遍历和中序遍历建成树的时候,是根据前序遍历的根结点找到其在中序遍历中的位置确定左右子树

一般是通过循环找到in[i]=pre[prerooot]这样

int inroot=inl;
while(inroot<inr && in[inroot]!=pre[preroot]) inroot++;

而在这里因为pos[i]存储的就是值为i的结点对应的中序遍历的下标可以直接用 inroor=pos[pre[preroot]]

完整代码

#include<bits/stdc++.h>
using namespace std;
int n;
vector<int> in,pre;
map<int,int> pos; 

void lca(int inl,int inr,int preroot,int a,int b){
	if(inl>inr) return;
	int inroot=pos[pre[preroot]];
	int ain=pos[a],bin=pos[b];
	if((ain>inroot && bin<inroot) ||(ain<inroot && bin>inroot)) printf("LCA of %d and %d is %d.\n",a,b,in[inroot]);
	else if(ain<inroot && bin<inroot) lca(inl,inroot-1,preroot+1,a,b);
	else if(ain>inroot && bin>inroot) lca(inroot+1,inr,preroot+1+(inroot-inl),a,b);
	else if(ain==inroot) printf("%d is an ancestor of %d.\n",a,b);
	else if(bin==inroot) printf("%d is an ancestor of %d.\n",b,a);
}

int main(){
	int m,i,u,v;
	scanf("%d %d",&m,&n);
	in.resize(n+1);
	pre.resize(n+1);
	for(i=1;i<=n;i++){
		scanf("%d",&in[i]);
		pos[in[i]]=i;	
	}
	for(i=1;i<=n;i++) scanf("%d",&pre[i]);
	while(m--){
		scanf("%d %d",&u,&v);
		if(pos[u]==0 && pos[v]==0) printf("ERROR: %d and %d are not found.\n",u,v);
		else if(pos[u]==0 || pos[v]==0) printf("ERROR: %d is not found.\n",pos[u]==0?u:v);
		else lca(1,n,1,u,v); 	
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值