1151 LCA in a Binary Tree (30 分)
The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
Given any two nodes in a binary tree, you are supposed to find their LCA.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.
Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…
Sample Input:
6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
给定二叉树的先序和中序遍历,求两个结点的最近公共祖先。
先建树,再递归查找公共祖先,以为会超时,竟然没有。
#include<iostream>
#include<cstdio>
#include<map>
using namespace std;
const int maxn = 10010;
int in[maxn];
int pre[maxn];
struct node{
int val;
node* left;
node* right;
};
map<int,node*>mp;
node* create(int preL,int preR,int inL,int inR){
if(inL>inR) return NULL;
node* now = new node;
now->val = pre[preL];
int i;
for(i=inL;i<=inR;i++){
if(in[i]==pre[preL]) break;
}
int numLeft=i-inL;
now->left=create(preL+1,preL+numLeft,inL,i-1);
now->right=create(preL+numLeft+1,preR,i+1,inR);
mp[now->val]=now;
return now;
}
node* lca(node* root,node* a,node* b){
if(root==NULL || root==a || root==b) return root;
node* L = lca(root->left,a,b);
node* R = lca(root->right,a,b);
if(L==NULL) return R;
if(R==NULL) return L;
return root;
}
int main()
{
int m,n;
scanf("%d %d",&m,&n);
for(int i=0;i<n;i++){
scanf("%d",&in[i]);
}
for(int i=0;i<n;i++){
scanf("%d",&pre[i]);
}
node* root = create(0,n-1,0,n-1);
for(int i=0;i<m;i++){
int a,b;
scanf("%d %d",&a,&b);
if(!mp[a] && !mp[b]) printf("ERROR: %d and %d are not found.\n",a,b);
else if(!mp[a]) printf("ERROR: %d is not found.\n",a);
else if(!mp[b]) printf("ERROR: %d is not found.\n",b);
else{
node* res = lca(root,mp[a],mp[b]);
if(res->val==a)
printf("%d is an ancestor of %d.\n",a,b);
else if(res->val==b)
printf("%d is an ancestor of %d.\n",b,a);
else
printf("LCA of %d and %d is %d.\n",a,b,res->val);
}
}
return 0;
}