甲级PAT 1032 Sharing (25 分)(链表)

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题目要求 

找出两个链表第一个公共的结点对应的id,如果没有找到输出-1

解题思路

利用数组下标表示当前id的结点,然后将第一条链表遍历,每个结点设置flag为true,遍历第二个链表的时候,如果遇到了flag为true的结点,则表示遇到了第一个公共结点,如果找到-1还没有找到,则说明没有

注意

输出格式,如果找到2需要输出00002

完整代码

#include<bits/stdc++.h>
using namespace std;

struct Node{
	int next;
	char data;
	bool flag;
}node[100010];

int main(){
	int start1,start2,n,i,u,v;
	char c;
	cin>>start1>>start2>>n;
	for(i=0;i<n;i++){
		cin>>u>>c>>v;
		node[u].data=c;
		node[u].next=v;
		node[u].flag=false;
	}
	while(start1!=-1){
		node[start1].flag=true;
		start1=node[start1].next;
	}
	while(!node[start2].flag && start2!=-1){
		start2=node[start2].next;
	}
	if(start2==-1) cout<<-1;
	else printf("%05d",start2);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值