PAT甲级:1032 Sharing

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

在这里插入图片描述
Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10
​5
​​ ), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next
whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

实现思路:第一次

创建数组链表,先存储,循环第二条链表,然后都用flag作为标记,如果存在则为true,
遍历第二个链表,如果出现true就存在相同的节点,不然就输出-1,题解还有记得输出格式为5位数,不足的0补;

代码

package test;

import java.io.BufferedInputStream;
import java.text.DecimalFormat;
import java.util.Scanner;

public class pat_a_1032 {
    public static void main(String[] args) {
        Scanner sc = new Scanner(new BufferedInputStream(System.in));
        int s1,s2,n;
        s1=sc.nextInt();s2=sc.nextInt();n=sc.nextInt();sc.nextLine();
       // StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
        //String str[] = in.
        DecimalFormat df = new DecimalFormat("00000");

         int a;
        NODE node[] = new NODE[100010];
        for(int i=0;i<n;i++){
            a=sc.nextInt();
            node[a]=new NODE();
            node[a].key=sc.next().charAt(0);
            node[a].next=sc.nextInt();
            sc.nextLine();
        }
        for(int p=s1;p!=-1;p=node[p].next){
            node[p].flag=true;
        }
        for(int p=s2;p!=-1;p=node[p].next) {
            if (node[p].flag == true) {
                System.out.println(df.format(p));
                return;
            }
        }
        System.out.println("-1");
        return;
    }
}
class NODE{
    int next;
    char key;
    boolean flag;
}

结果最后一个超时:
修改,第一感觉就是scanner占用太多的时间了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wvdon

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值