甲级PAT 1138 Postorder Traversal (25 分)(先序中序转后序)

1138 Postorder Traversal (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

题目说明以后补。

完整代码 

#include<bits/stdc++.h>
using namespace std;
int pre[50010],in[50010],post[50010],num=0;

void tra(int root,int start,int end){
	if(start>end) return;
	int i=start;
	while(in[i]!=pre[root]) i++;
	tra(root+1,start,i-1);
	tra(root+(i-start)+1,i+1,end);
	post[num++]=pre[root];
} 

int main(){
	int n,i;
	cin>>n;
	for(i=0;i<n;i++) cin>>pre[i];
	for(i=0;i<n;i++) cin>>in[i];
	tra(0,0,n-1);
	cout<<post[0];
	
	return 0;
}

 

在C++中,树的先序遍历(前序遍历)、中序遍历和后序遍历是三种基本的遍历方法,它们别对应于在访问节点和子树时的不同顺序。 1. 先序遍历(Preorder Traversal):先访问根节点,然后递归地先序遍历左子树,最后递归地先序遍历右子树。遍历顺序为:根 -> 左 -> 右。 2. 中序遍历(Inorder Traversal):首先递归地中序遍历左子树,然后访问根节点,最后递归地中序遍历右子树。遍历顺序为:左 -> 根 -> 右。 3. 后序遍历(Postorder Traversal):首先递归地后序遍历左子树,然后递归地后序遍历右子树,最后访问根节点。遍历顺序为:左 -> 右 -> 根。 下面是三种遍历方法的C++代码示例: ```cpp #include <iostream> using namespace std; struct TreeNode { int val; TreeNode *left; TreeNode *right; TreeNode(int x) : val(x), left(NULL), right(NULL) {} }; // 先序遍历 void preorderTraversal(TreeNode* root) { if (root == NULL) return; cout << root->val << " "; preorderTraversal(root->left); preorderTraversal(root->right); } // 中序遍历 void inorderTraversal(TreeNode* root) { if (root == NULL) return; inorderTraversal(root->left); cout << root->val << " "; inorderTraversal(root->right); } // 后序遍历 void postorderTraversal(TreeNode* root) { if (root == NULL) return; postorderTraversal(root->left); postorderTraversal(root->right); cout << root->val << " "; } int main() { // 构建一棵树作为示例 TreeNode *root = new TreeNode(1); root->left = new TreeNode(2); root->right = new TreeNode(3); root->left->left = new TreeNode(4); root->left->right = new TreeNode(5); cout << "先序遍历结果: "; preorderTraversal(root); cout << endl; cout << "中序遍历结果: "; inorderTraversal(root); cout << endl; cout << "后序遍历结果: "; postorderTraversal(root); cout << endl; // 注意:这里没有释放树节点所占用的内存,实际使用时应避免内存泄漏 return 0; } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值