多校2.1012La Vie en rose

点击打开链接

Problem Description
Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string  p=p1p2...pm . So, he wants to generate as many as possible pattern strings from  p  using the following method:

1. select some indices  i1,i2,...,ik  such that  1i1<i2<...<ik<|p|  and  |ijij+1|>1  for all  1j<k .
2. swap  pij  and  pij+1  for all  1jk .

Now, for a given a string  s=s1s2...sn , Professor Zhang wants to find all occurrences of all the generated patterns in  s .
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains two integers  n  and  m   (1n105,1mmin{5000,n})  -- the length of  s  and  p .

The second line contains the string  s  and the third line contains the string  p . Both the strings consist of only lowercase English letters.
 

Output
For each test case, output a binary string of length  n . The  i -th character is "1" if and only if the substring  sisi+1...si+m1  is one of the generated patterns.
 

Sample Input
  
  
3 4 1 abac a 4 2 aaaa aa 9 3 abcbacacb abc
 

Sample Output
  
  
1010 1110 100100100


题意:给一个原串给一个匹配串,匹配串可以任选一些不相邻的字符,把这些字符和相邻的字符交换,匹配成功串首为1,else0;


解:标程用的bitset,不晓得是什么阿..暴力如下:

<pre name="code" class="cpp">
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;


char ans[100000 + 5];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m;
        cin>>n>>m;
        string a, b;
        cin>>a>>b;
        memset(ans, '1', sizeof ans);
        for(int i = 0; i <= n-m; i++)
        {

            for(int j = 0; j < m; j++)
            {
                if(a[i+j] == b[j])
                    ;
                else if(j < m-1 && a[i+j] == b[j+1] && a[i+j+1] == b[j])      // 交换匹配,先控制范围
                    j++;
                else
                {
                    ans[i] = '0';
                    break;
                }
            }

        }
        for(int i = 0; i < n-m+1; i++)
            cout<<ans[i];
        while(--m)
            cout<<'0';                                 //倒数几个长度不够的一定匹配不到。

        cout<<endl;
    }
    return 0;

}


 







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值