《ACM程序设计》书中题目N(倒序相加)

Description

The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously, this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted into the comedy play.

Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros.

ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).


Input



The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add.


Output



For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.


Sample Input



3
24 1
4358 754
305 794


Sample Output



34
1998
1


题目大意就是说给两个数倒过来相加再倒过来,首位是0的话就删掉;

思路如下:

1.编写一个将整数倒序输出的函数;

2.直接用,不多逼逼;


代码如下:

#include<bits/stdc++.h>
using namespace std;
int re(int a)   //倒序输出
{
        int b=0;
        while(a)
	{
		b=a%10+10*b;   //原理是将a从个位开始截取数放到b的最高位上,a为0时结束
		a=a/10;
	}
	return b;   //b就是a的倒序
}
int main()
{
        int i,n,x,y;
        cin>>n;
        for(i=0;i<n;i++)
        {
                cin>>x>>y;
                cout<<re(re(x)+re(y))<<endl;
        }
}


之前想过利用字符串去解决,但是这种方式更便于处理首位为0的情况,而且复杂度也较小。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值