Adding Reversed Numbers 数的反转

Adding Reversed Numbers

Time Limit: 1 Sec   Memory Limit: 64 MB
Submit: 300   Solved: 143
[ Submit][ Status][ Discuss]

Description

The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously, this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted into the comedy play. Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros. ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add. Numbers will be at most 200 characters long.

Output

For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.

Sample Input

3
24 1
4358 754
305 794

Sample Output

34
1998
1

一个数若有200个字符的长度,他没有爆int,所以此题可直接用int来做,题目的核心精华之处就是如何将一个数的顺序倒过来,如将123变成321,120变成21(应当注意前导零的去除)。AC代码:
#include<stdio.h>
int con(int x)
{
    int i,ans=0;
    while(x)
    {
        ans=ans*10+x%10;   //一种记忆化思想,数字的组成即以十为单位变化,(通俗来说就是每个数字后面没多一个数,该数字就乘10                           //         ),ans是前辈(已经加的数),x%10是小辈(将要加的数)。
        x/=10;
    }
    return ans;
}
int main()
{
    int i,a,b,n,x;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d %d",&a,&b);        
            x=con(a)+con(b);                //由题意知,该题有3处用到了数的反转,故用被调函数可使代码可读性提高,简洁明了.
            printf("%d\n",con(x));
        }
    }
    return 0;
}



  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值