Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:
- Emergency 911 - Alice 97 625 999 - Bob 91 12 54 26In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.
Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000.Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output "YES" if the list is consistent, or "NO" otherwise.
Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES
题目大意是给出一组号码,判断它们会不会相互冲突(就是一个号码没拨完就转接到另一个号码上);
思路如下:
1.建立字符串数组储存号码;
2.将数组字典序有大到小排序;
3.检查数组中每一个字符串的上一个字符串是否为该字符串的子集(也就是该字符串的前几位是否和上一个一样),若是,输出结果并结束循环,若不是,循环结束后输出结果;
程序如下:
#include<bits/stdc++.h>
using namespace std;
int main()
{
string s;
int i,n,m,j;
cin>>n;
for(i=0;i<n;i++)
{
vector<string> v;
cin>>m;
for(j=0;j<m;j++)
{
cin>>s;
v.push_back(s); //字符串存入数组
}
sort(v.begin(),v.end()); //按字典序排序
for(j=0;j<m-1;j++)
{
if(v[j+1].find(v[j])==0) //判断是否为子集
{
cout<<"NO"<<endl;
goto A;
}
}
cout<<"YES"<<endl;
A:;
}
}